You are here: start » it » guides » highdesign » r5 » modifica-oggetti

7 Modificare Oggetti ed Elementi

7 Modificare Oggetti ed Elementi

  • Funzioni del Menu Modifica
  • Modificare Oggetti Grafici
  • Modifiche Avanzate

Funzioni del Menu Modifica

Il menu Modifica è comunemente usato per i comandi standard come annullare e ripetere un'operazione; tagliare, copiare, incollare e cancellare; selezionare; funzione di ricerca; ordinare e allineare gli elementi. Fornisce anche la possibilità di aprire la finestra delle Impostazioni degli Strumenti.

Annullare / Ripetere un'operazione

La maggior parte delle operazioni in HighDesign può essere annullata (e rifatta) fino a 300 passi indietro, dando così la massima libertà di sperimentazione.

“Annulla” e “Ripeti” si applicano alle seguenti azioni:

  • Creazione di nuovi elementi (ad es. nuova linea, nuova bézier, ecc.)
  • Cancellazione di uno o più elementi selezionati
  • Modifica degli elementi selezionati (ad es. estendi, modifica, taglia, trascina, ecc.)
  • Operazioni complesse (ad es. arrotonda, smussa, incolla, ecc.)

In situazioni particolari, può essere utile sospendere il sistema di registrazione delle azioni utilizzato dai comandi Annulla/Ripeti per salvare la memoria RAM. Il comando Sospendi Annulla permette di mettere temporaneamente in pausa il sistema di Annulla.

Taglia, Copia, Incolla e Cancella

Queste sono funzioni standard che si trovano in tutti i programmi e forniscono alcune azioni semplici ma utili:

  • Con Taglia gli elementi selezionati verranno cancellati dal disegno e messi in memoria per un uso successivo;
  • Usando Copia gli elementi selezionati verranno copiati in memoria, senza rimuoverli dal progetto;
  • Incolla consente di inserire gli elementi memorizzati;
  • Cancella si usa per eliminare gli elementi selezionati da un progetto.

Gli oggetti copiati da HighDesign non vengono memorizzati negli appunti del sistema, ma utilizzano piuttosto un metodo interno di copia e incolla, in modo che gli appunti del sistema siano disponibili per immagini e testi.

Il comando Incolla apre una finestra di dialogo con opzioni che permettono di scegliere la fonte da cui incollare gli oggetti, sia gli appunti di sistema che gli appunti di HighDesign. Altre opzioni includono la posizione dell'oggetto incollato e il lucido di destinazione.

Copia come Immagine

Le voci del menu Copia Come Immagine consentono di copiare gli oggetti selezionati come immagine negli appunti del sistema, per l'utilizzo in altri software di grafica. Gli oggetti vengono copiati come immagini in uno dei seguenti formati e risoluzioni:

  • PNG a 72 DPI
  • PNG a 300 DPI
  • PNG a 300 DPI con canale alfa
  • JPEG a 72 DPI
  • GIF

Gli oggetti vengono copiati al fattore di zoom corrente, e più alta è la risoluzione, più memoria è necessaria per creare l'immagine. Poiché i progetti in HighDesign sono fatti di elementi vettoriali che possono essere ingranditi quasi all'infinito, è possibile incorrere in situazioni di bassa memoria quando si copia un grande progetto come immagine. Ridurre il valore di zoom o copiare un'area alla volta per aggirare eventuali limitazioni hardware.

Selezione

Il menu Modifica include comandi per selezionare rapidamente gli elementi con alcune condizioni. Ad eccezione del comando “Seleziona Tutti i Fogli”, tutte le funzioni di selezione si applicano al foglio corrente. I comandi di selezione seguono lo stato dei lucidi, e gli elementi sui lucidi nascosti o bloccati non vengono selezionati.

  • “Seleziona Tutti i Fogli” seleziona tutti gli elementi su tutti i fogli di disegno;
  • Il comando “Seleziona Tutto” seleziona tutti gli elementi sul foglio corrente;
  • “Seleziona il Lucido Corrente” per selezionare tutti gli oggetti con il lucido corrente;
  • “Seleziona Tutti <tipo di oggetto>…” seleziona tutti gli elementi sul foglio corrente dello stesso tipo dello strumento di disegno attualmente selezionato;
  • “Inverti Selezione” seleziona tutti gli elementi e deseleziona quelli già selezionati;
  • “Deseleziona” deseleziona tutti gli elementi attualmente selezionati.
  • “Ripristina Ultima Selezione”: ripristina l'ultima selezione utilizzata anche dopo essere stata disattivata.

Gli elementi di disegno possono essere selezionati tramite lo strumento Freccia o premendo il tasto Shift e cliccando sull'elemento o cliccando con il tasto destro del mouse. Vedi anche il paragrafo “Freccia e Selezione” al capitolo 5.

Funzioni di Ricerca: il comando "Cerca"

Per cercare gli elementi all'interno di un progetto selezionare Modifica ▸ Cerca… per aprire la finestra “Cerca”. La finestra di dialogo Cerca consente di selezionare gli elementi all'interno dei criteri di impostazione del foglio corrente per ridurre la portata della funzione.

La parte superiore della finestra di ricerca mostra i pulsanti corrispondenti agli oggetti grafici che si desidera trovare all'interno del foglio attualmente selezionato. Questi oggetti sono disposti in tre gruppi: oggetti di Disegno, oggetti di Documentazione ed elementi Architettonici.

I criteri di ricerca facoltativi offrono i menu e i campi necessari per filtrare la ricerca.

Criteri di Ricerca:

  • Tipo di Oggetto: premere il pulsante corrispondente al tipo di oggetto che si desidera trovare;
  • Foglio: selezionare il foglio (foglio di disegno, dettaglio o layout);
  • Stile/Tipo: cercare gli oggetti con uno stile o un tipo;
  • Lucido: cercare gli elementi all'interno del lucido selezionato;
  • Colore della Penna: colore del contorno degli oggetti da cercare;
  • Tipo di linea: tipo di linea del contorno degli oggetti da cercare;
  • Spessore della penna: spessore della penna degli oggetti da trovare;
  • Testo: ricerca di tutte le occorrenze del testo nel disegno;
  • Tag: inserire il tag noto per cercare gli elementi con quel tag;
  • Nome: inserire il nome degli elementi architettonici;
  • Descrizione: inserire la descrizione per cercare gli elementi architettonici corrispondenti.

Sono disponibili tre opzioni: selezionare tutti gli elementi che corrispondono ai criteri attivi (“Trova tutti”); selezionare solo un elemento corrispondente (“Trova successivo”). Selezionando l'opzione “Zoom sulla Selezione” si può far scorrere automaticamente la pagina per centrare la vista sulla selezione.

Ordina

Gli oggetti di disegno vengono visualizzati a schermo (e stampati) con l'ordine di creazione: il primo oggetto creato è dietro a tutti gli altri. Se si posiziona un riempimento opaco sopra gli altri oggetti, esso coprirà tutto ciò che si trova dietro di esso.

È possibile modificare questo ordine inviando indietro o davanti le voci selezionate utilizzando le opzioni del sottomenu Ordina del Menu Modifica:

  • “Metti Davanti ” invia gli elementi selezionati davanti a tutti gli altri elementi; se la selezione contiene due o più elementi, questi vengono spostati con il loro ordine interno;
  • “Sposta in Avanti” sposta gli elementi selezionati verso l'alto di una posizione;
  • “Sposta Indietro“ sposta gli elementi selezionati verso il basso di una posizione;
  • “Metti Sotto” sposta gli elementi selezionati in fondo a tutti gli altri elementi.

Allinea

Questo comando sposta gli oggetti selezionati ordinandoli in base alla loro posizione e alla regola scelta. Gli allineamenti per direzione utilizzano il primo oggetto in quella direzione tra gli oggetti selezionati. Ad esempio, Allinea al margine sinistro utilizza il punto più a sinistra di tutti gli oggetti selezionati come margine di allineamento sinistro.

Le regole di allineamento sono:

  • Margine sinistro;
  • Centro nella colonna: allinea gli oggetti verticalmente;
  • Margine superiore;
  • Centro in riga: allinea gli oggetti orizzontalmente;
  • Margine inferiore.

Distribuisci

Ogni oggetto ha un riquadro di delimitazione che definisce gli estremi massimi delle sue dimensioni. Il comando Distribuisci consente di posizionare gli oggetti selezionati in base allo spazio tra i rettangoli di delimitazione. Il primo e l'ultimo oggetto nella direzione selezionata definiscono i margini.

Le opzioni sono:

  • Margine sinistro
  • Centro in fila
  • Margine destro
  • Spaziatura orizzontale:
  • Margine superiore
  • Centro in colonna
  • Margine inferiore
  • Spaziatura verticale

Modificare Oggetti Grafici

Muovi

Utilizzare questa funzione per spostare gli elementi selezionati. Scegliere Disegno ▸ Muovi, quindi fare clic per impostare un punto di partenza, spostare il puntatore e fare clic di nuovo per impostare la direzione e lo scostamento della traslazione.

Si applica a: oggetti selezionati

Passi:

  1. Definire il punto di partenza, l'origine della traslazione;
  2. Definire il punto finale.

Vincoli disponibili:

  • Lunghezza (L + valore; valore)
  • Angolo (A + valore).

Tenendo premuto il tasto Alt, lo strumento Muovi si trasforma in Duplica. Il comando Muovi può essere attivato anche in altri modi:

  • Con lo strumento Selezione, o durante la modifica di un oggetto, cliccando sul punto centrale, se disponibile;
  • Con i tasti Freccia, o Shift + Freccia se impostato in Preferenze ▸ Ambiente, per spostare gli oggetti selezionati di un'unità lineare; tenendo premuto il tasto Alt lo spostamento viene moltiplicato per 10.
  • Tenendo premuto il tasto Cmd, si può cliccare su un oggetto e iniziare un comando Muovi con una sola operazione.

Duplica

Questa funzione crea una copia degli elementi selezionati con uno scostamento definito.

La funzione Duplica può anche essere attivata dallo strumento Freccia premendo il tasto Opzione mentre si spostano gli elementi selezionati.

Tenere premuto il tasto Command per effettuare più copie della stessa selezione in una sola sessione.

Si applica a: oggetti selezionati

Passi:

  1. Definire il punto di partenza, l'origine della traslazione;
  2. Definire il punto finale.

Vincoli disponibili:

  • Lunghezza (L + valore; valore)
  • Angolo (A + valore).

Moltiplica/Distribuisci Lineare

Questa funzione crea un numero di copie degli elementi selezionati. Il metodo può essere Incremento, dove la distanza tra il punto iniziale e finale definisce la distanza tra ogni copia, oppure Distribuisci, dove la distanza definisce il valore dell'estensione massima delle copie. Con questa opzione, la distanza tra le copie viene calcolata sul numero di copie.

Si applica a: oggetti selezionati

Passi:

  1. Impostare il numero di copie e il metodo, Incremento o Distribuzione;
  2. Definire il punto di partenza, l'origine della traslazione;
  3. Definire il punto finale.

Vincoli disponibili:

  • Lunghezza (L + valore; valore);
  • Angolo (A + valore).

La finestra di dialogo Moltiplica/Distribuisci può essere utilizzata interamente con la tastiera: i tasti freccia Su e Giù controllano il numero di copie; Comando + freccia Su/Giù controllano i tasti di opzione.

Moltiplica/Distribuisci Polare

Utilizzare questo strumento per creare copie multiple di oggetti selezionati lungo un arco di cerchio. La voce di menu Disegno ▸ Moltiplica Polare apre la finestra di dialogo di immissione utilizzata per inserire il numero di copie e selezionare tra incremento e distribuzione.

Si applica a: oggetti selezionati

Passi:

  1. Impostare il numero di copie e il metodo, Incremento o Distribuzione;
  2. Definire il centro di rotazione;
  3. Definire il punto di inizio dell'arco
  4. Definire il punto finale dell'arco.

Vincoli disponibili: Angolo (A + valore).

La finestra di dialogo Moltiplica/Distribuisci Polare può essere utilizzata tramite la tastiera: i tasti freccia Su e Giù controllano il numero di copie; Comando + Freccia Su/Giù controllano i tasti di opzione.

Ruota

Questa funzione consente di ruotare gli elementi selezionati attorno ad un punto centrale e con un angolo definito graficamente.

Si applica a: oggetti selezionati

Passi:

  1. Definire il primo punto, il punto centrale della rotazione;
  2. Definire il punto di partenza;
  3. Definire il punto finale e l'angolo.

Vincoli disponibili: Angolo (A + valore).

È anche possibile inserire un valore di angolo di rotazione premendo il tasto “A” sulla tastiera tra i passi 2 e 3.

Angolo di Rotazione

Utilizzare questo strumento per ruotare gli oggetti selezionati in tempo reale. Il centro della rotazione può essere assoluto, che è il punto medio del riquadro di selezione, o il centro dell'oggetto, che ruota ogni oggetto intorno al proprio centro.

Si applica a: oggetti selezionati.

Passi:

  1. Nella finestra Angolo di Rotazione, impostare l'angolo utilizzando il controllo o inserendo il valore nel campo di immissione;
  2. Scegliere tra il centro globale della selezione e il centro relativo del singolo oggetto.

Ribalta

Questo comando trasforma gli oggetti ribaltando la selezione attorno ad un asse arbitrario:

Si applica a: oggetti selezionati.

Passi:

  1. Definire il punto di partenza, l'origine dell'asse;
  2. Definire il punto finale, angolo dell'asse.

Vincoli disponibili: Angolo (A + valore).

Ribalta e Duplica

Proprio come Ribalta, questa funzione crea una copia speculare degli elementi selezionati. La procedura è la stessa del comando “Ribalta” descritto sopra.

Si applica a: oggetti selezionati.

Passi:

  1. Definire il punto di partenza, l'origine dell'asse;
  2. Definire il punto finale, l'angolo dell'asse.

Vincoli disponibili: Angolo (A + valore).

Stira

Utilizzare questo comando per spostare e ridimensionare / allungare gli oggetti all'interno del rettangolo di selezione: gli oggetti che si trovano interamente all'interno del rettangolo di selezione verranno spostati, mentre tutti gli altri oggetti verranno ridimensionati. Archi, cerchi, ellissi, blocchi di testo, porte/finestre e simboli verranno trascinati rigidamente senza alcun cambiamento di forma.

Si applica a: oggetti selezionati.

Passi:

  1. Definire il punto di partenza, l'origine della traslazione;
  2. Definire il punto finale.

Vincoli disponibili:

  • Lunghezza (L + valore; valore);
  • Angolo (A + valore).

Ridimensiona Disegno

Utilizzare lo strumento Ridimensiona Disegno per modificare le dimensioni del disegno di un valore percentuale o per valori numerici di larghezza e altezza. La dimensione può essere resa indipendente o proporzionale cliccando sull'icona del lucchetto. I valori possono essere inseriti in percentuale o in una qualsiasi delle unità lineari supportate.

Attivando la casella di controllo “Ridimensiona l'intero disegno tramite selezione”, l'intero disegno verrà ridimensionato dello stesso valore applicato alla selezione. Questo è particolarmente utile quando il disegno non è in scala (di solito un disegno importato o un file di immagine inserito) ed è necessario ridimensionarlo. In questo caso, è possibile selezionare un elemento di dimensioni note, aprire la finestra Ridimensiona Disegno, attivare la casella di controllo e inserire i valori reali. L'intero disegno verrà ridimensionato di conseguenza.

Si applica a: intero disegno / oggetti selezionati.

Passi: inserire uno o entrambi i valori di dimensione.

Vincoli disponibili: valori proporzionali.

Segna Intersezioni

Questa funzione trova tutte le intersezioni tra due elementi lineari selezionati (linee, poli-linee, muri). Le intersezioni sono contrassegnate da punti.

Si applica a: oggetti selezionati.

Passi: comando diretto.

Unisci

Questo comando estende due linee o muri selezionati fino alla loro intersezione: se le linee non si intersecano, vengono estese; se si intersecano tra loro, la funzione le accorcia fino al punto di intersezione.

Questo comando non può essere applicato agli elementi paralleli.

Si applica a: oggetti selezionati.

Passi: comando diretto.

Estendi

Questa funzione estende le linee selezionate (allungandole o accorciandole) fino al loro punto di intersezione con un altro oggetto. I tipi supportati sono: Linea di costruzione, Linea, Poligono, Rettangolo, Linea a mano libera, Curva di Bézier, Arco / cerchio, Muro.

Si applica a: linee o muri selezionati.

Passi: clicca sull'oggetto di destinazione.

Dividi

Questa funzione divide in segmenti le linee che intersecano altre linee, poli-linee, rettangoli, tratteggi, archi, cerchi, linee a mano libera e curve di bezier:

Si applica a: linee selezionate.

Passi: clicca sull'oggetto di destinazione.

Ritaglia

La funzione Ritaglia è una funzione multiuso progettata per eliminare tratti lineari o curvi o sezioni. Si applica a singoli segmenti senza intersezioni con altri oggetti così come a segmenti intersecati da altri oggetti.

Segmenti senza intersezioni

Attivare lo strumento e cliccare sul segmento da cancellare: se il segmento tagliato apparteneva ad un rettangolo o ad un poligono, i segmenti rimanenti vengono trasformati in poli-linee.

Segmenti che intersecano altri oggetti

Attivare Ritaglia e cliccare sul segmento o parte di segmento da cancellare: utilizzare questo strumento per cancellare un disegno e tagliare segmenti, archi e curve tra le intersezioni o che si estendono al di fuori di un margine con un semplice clic.

Per applicarlo:

  1. Scegliere Disegno Ritaglia o cliccare sull'icona corrispondente della barra degli Strumenti di Modifica;
  2. Un aiuto visivo evidenzia i segmenti sotto il puntatore;
  3. Fare clic sulle parti degli oggetti che si desidera ritagliare;
  4. Tutti i segmenti e le porzioni di archi tra le intersezioni o che si estendono al di fuori del contorno saranno cancellati;
  5. Fare clic su una regione vuota per uscire da questo comando o premere il tasto Esc.

È anche possibile attivare il comando Ritaglia tenendo premuti i tasti Indietro o Canc sulla tastiera e cliccando sull'oggetto, oppure cliccando con la punta della gomma di una penna di tavoletta grafica. Per utilizzare questa funzione non è necessaria alcuna selezione.

Quando si attiva con una selezione, gli oggetti selezionati agiscono come “ taglierine” e controllano le intersezioni. Tutte le intersezioni che non appartengono ad un oggetto selezionato vengono ignorate.

Si applica a: oggetti al clic.

Passi: clicca sull'oggetto di destinazione.

Dividi in Parti

Questo comando viene utilizzato per dividere la linea selezionata nel numero di segmenti uguali specificati nella finestra di dialogo “Dividi in”. Questa finestra di dialogo permette anche di scegliere se dividere la linea con punti di riferimento o se creare effettivamente dei segmenti.

La finestra di dialogo “Dividi in“ può essere utilizzata tramite la tastiera: i tasti freccia Su e Giù controllano il numero di divisioni; il tasto Command + Freccia Su/Giù controlla i pulsanti di opzione.

Si applica a: oggetti selezionati.

Passi: imposta il numero di parti.

Interrompi

Questo strumento permette di definire un segmento che verrà sottratto da una linea selezionata creando una interruzione. Selezionare Disegno Break, cliccare su una linea per impostare il primo punto del segmento e cliccare di nuovo per impostare il punto finale.

Si applica a: oggetti selezionati.

Passi:

  1. Definire il primo punto;
  2. Definire il secondo punto.

Modificare Elementi del Progetto

Arrotonda / Smussa

Questi comandi permettono di unire due segmenti, linee o poli-linee, con un arco di un dato raggio, o con una corda di una data lunghezza. Ci sono due modi per utilizzare questi strumenti:

Numerico:

  1. Selezionare due segmenti non paralleli;
  2. Scegliere Strumenti Arrotonda o Strumenti Smussa o cliccare sull'icona corrispondente della barra degli strumenti;
  3. Un campo di testo appare vicino all'icona dello strumento: inserire il valore del raggio o della lunghezza della corda e premere Invio.

Grafico:

  1. Selezionare due segmenti;
  2. Scegliere Strumenti Arrotonda o Strumenti Smussa o cliccare sull'icona corrispondente della barra degli strumenti;
  3. Fare clic sull'impugnatura bianca del raggio/corda e spostare il puntatore lungo la direzione vincolata perpendicolare al raggio/corda per ridimensionarne la lunghezza;
  4. Cliccare di nuovo per confermare.

Quando si applica alle poli-linee, è possibile cambiare il vertice da modificare posizionando il cursore sul vertice e attendere un secondo fino all'aggiornamento dell'anteprima.

Offset

Questo strumento è utilizzato per creare duplicati concentrici di oggetti lineari (linee, poligoni, rettangoli, poli-linee, linee a mano libera, archi, cerchi ed ellissi) ad una data distanza.

Per attivare il comando, selezionare gli oggetti e andare su Strumenti Offset: inserire la distanza nel campo di testo che appare vicino all'icona dello strumento, poi cliccare sulla maniglia bianca e spostare il puntatore per scegliere il lato su cui si vuole posizionare il duplicato.

Cliccate sugli altri oggetti se volete applicare il comando con le impostazioni correnti ad altri oggetti. Premere ESC per concludere il comando.

Estrudi 2D

Questa funzione grafica simula l'estrusione lungo una direzione degli oggetti selezionati creando generatrici dai vertici e un duplicato della selezione.

Esplodi

La maggior parte degli oggetti di disegno, come poligoni, poli-linee, linee a mano libera, curve di Bézier, archi e cerchi, ellissi, poligoni tratteggiati, simboli, muri, finestre e colonne, possono essere convertiti in oggetti più semplici con il comando Esplodi.

Selezionare gli elementi che si desidera semplificare e scegliere Strumenti Esplodi: tutti gli elementi selezionati vengono convertiti in linee e l'oggetto sorgente viene cancellato. I simboli vengono convertiti nei loro elementi di base.

Converti in Poli-linea

Utilizzare questo comando per convertire gli oggetti selezionati e collegati (linee e archi, poligoni regolari e rettangoli) in poli-linee.

Applica Retino

Questo comando applica un tratteggio o un riempimento alla regione descritta dagli elementi selezionati. Gli elementi di delimitazione supportati sono:

  • Linee collegate dai loro vertici (“linee segmentate”);
  • Poli-linee;
  • Poligoni;
  • Linee a mano libera;
  • Curve di Bézier;
  • Spline;
  • Archi;
  • Cerchi;
  • Ellissi

Per utilizzare questo strumento, selezionare gli elementi di contorno, quindi scegliere Strumenti Applica Retino: viene creato un nuovo riempimento / tratteggio con le impostazioni correnti dello strumento “Retini e Riempimenti”.

Calcola Area

Questa funzione calcola l'area di una regione racchiusa dagli elementi selezionati. Gli elementi di delimitazione supportati sono:

  • Linee collegate dai loro vertici (“linee segmentate”);
  • Poli-linee;
  • Poligoni;
  • Linee a mano libera;
  • Curve di Bézier;
  • Spline;
  • Cerchi, archi, ellissi.

Per utilizzare questo comando, selezionare gli elementi di delimitazione, quindi scegliere Strumenti ▸ Calcola area: al centro della selezione viene creata una nuova etichetta di testo che mostra l'area della regione nelle unità correnti.

Trova Baricentro

La funzione “Trova Baricentro” calcola la posizione del centro di massa dei poligoni selezionati, delle poli-linee chiuse o dei tratteggi. Per calcolare il centro di massa di regioni curve come cerchi o béziers, è possibile esploderli e poi applicare questo comando alle linee selezionate.

Tangenti a Due Cerchi

Questo strumento trova quattro punti che definiscono le linee tangenti a due cerchi. Per utilizzare questo comando, selezionare due cerchi o archi di cerchio, quindi scegliere Strumenti Tangenti a due cerchi.

Adatta Area di Testo

Quando si cambia font o stile al paragrafo o anche quando si importano testi da altre applicazioni, la casella di testo può essere più grande o più piccola del suo contenuto effettivo: questo comando regola la dimensione delle caselle di testo selezionate.

/usr/www/users/ilexsoft/help.ilexsoft.com/data/pages/it/guides/highdesign/r5/modifica-oggetti.txt · Last modified: 2021/01/13 15:41 by editor_2