You are here: start » it » guides » highdesign-r6 » tecniche-essenziali

4 Tecniche Fondamentali

4 Tecniche Fondamentali

  • Snap ed Allineamenti
  • Vincoli di Disegno e Coordinate
  • Info Oggetto
  • Zoom e Posizione Quadro
  • Impostazione delle Proprietà Grafiche
  • Stili e Tipi

Snap ed Allineamenti

HighDesign fornisce snap alla griglia automatica, all'oggetto, al vertice, all'intersezione, all'angolo retto / tangente e agli allineamenti. La funzione di Snap permette di disegnare con la massima precisione impostando automaticamente l'inserimento sui punti di notevoli degli oggetti o unendo punti terminali di linee ed altri oggetti.

Gli snap possono essere attivati e disattivati attraverso il menu Snap sul lato inferiore sinistro della finestra principale nella Barra di Input. Le opzioni di Snap possono anche essere visualizzate come una pratica finestra mobile disponibile tramite il menu Finestra.

Tipi di Snap

La funzione Snap è sempre evidenziata da una forma diversa del puntatore, corrispondente alla condizione di snap attuale: se l'opzione “ Riproduci suoni” del pannello Ambiente di lavoro delle Preferenze HighDesign è attiva, la funzione Snap è evidenziata anche da un suono tipico.

Le opzioni di snap disponibili corrispondono ai seguenti tipi di snap:

  • Snap alla Griglia: il puntatore scatta alle intersezioni e sottodivisioni della griglia;
  • Snap al Punto Finale o al Vertice;
  • Snap all'Oggetto: il puntatore riconosce una distanza minima dal corpo di un oggetto;
  • Snap all'Intersezione: tutte le intersezioni sono interpretate come punti finali;
  • Snap all'Angolo Retto: il puntatore cambia quando il segmento corrente ne interseca un altro con un angolo retto;
  • Snap alla Tangente: il puntatore cambia quando la linea corrente è tangente ad un cerchio / arco;
  • Snap agli Allineamenti: il puntatore scatta a due guide temporanee;
  • Snap ai Sotto-oggetti: permette di scattare agli oggetti all'interno delle istanze dei simboli inseriti nel progetto e all'interno dei Viewport inseriti nei Layout.

Allineamenti

Quando il puntatore scatta su un punto terminale di un oggetto, quella posizione viene memorizzata come origine corrente delle guide temporanee; le guide vengono visualizzate quando il cursore si trova sull'asse X o sull'asse Y di quel punto di origine.

Il puntatore scatta anche all'intersezione delle guide: l'intersezione è evidenziata con un punto ed entrambe le guide sono visibili.

Inoltre, quando si posiziona il puntatore su un segmento, questa funzione memorizza l'angolo di quel segmento visualizzando le guide parallele e ortogonali corrispondenti: quando si traccia la retta, è sufficiente posizionare il puntatore su un punto di origine di quel segmento (punti finali o punto medio) per visualizzare l'allineamento.

Per disattivare temporaneamente lo Snap agli allineamenti, tenere premuto il tasto “cmd” o “ctrl”.

Vincoli di Disegno e Coordinate

Le funzioni dei Vincoli di Disegno consentono di disegnare rapidamente oggetti con alcune condizioni, come il parallelismo, i vincoli di angolo o le intersezioni. I campi di inserimento sulla Barra di Input consentono di inserire le coordinate dei punti di disegno e le dimensioni geometriche degli oggetti, come la lunghezza e l'angolo.

Direzioni Vincolate

Oggetti grafici lineari o poligonali come linee e Poli-linee, rettangoli ruotati, tratteggi, archi ed ellissi per raggio e diametro, quote e muri, possono essere disegnati allineati con uno degli assi cartesiani o ruotati con incrementi di 15 gradi: per fare questo è sufficiente premere il tasto Shift mentre si sposta il puntatore.

Pulsanti di Vincolo Parallelo, Angolo Retto e Allineato / Tangente

Questi tre pulsanti sulla Barra di Input forniscono i vincoli dell'Angolo Retto e del Parallelo e la condizione di Intersezione.

Vincolo Parallelo (P) e Angolo Retto (R)

Queste condizioni possono essere attivate in qualsiasi momento con qualsiasi strumento o funzione di editing e influenzeranno la direzione del movimento corrente.

Per attivare la condizione Angolo Retto o Parallelo:

  • Dopo il primo clic dell'operazione corrente che si sta eseguendo, cliccare il pulsante corrispondente alla condizione desiderata o premere il suo equivalente da tastiera (P o R);
  • Cliccare l'oggetto di riferimento, ad es. la linea che si vuole tracciare perpendicolare o parallela (il cursore del mouse si trasforma in una mano che indica quando è su un oggetto valido);
  • Per annullare una condizione, premere il tasto Esc della tastiera.

Vincolo Allineato/Tangente

Questa condizione vincola il puntatore a intersecare una linea o una circonferenza di riferimento, estendendo la linea che si sta tracciando fino al punto di intersezione, anche al di fuori dei limiti del segmento, o vincolando la direzione alla tangente.

Per attivare questa condizione, fare clic sul pulsante nella barra di inserimento o premere il suo equivalente da tastiera. Se la condizione viene attivata prima della definizione del punto di partenza, essa vincola il punto di partenza ad essere allineato alla linea o alla tangente alla circonferenza. Se attivata dopo il primo clic, vincola il punto finale.

Lo stesso risultato può essere ottenuto premendo il tasto Command + click sulla linea di origine mentre si disegna la linea, il poligono, il muro o il tratteggio / riempimento.

L'opzione Vincolo alla Tangente può essere attivata per costruire una linea tangente ad un arco o ad un cerchio, sia dal punto iniziale che dal punto finale.

Per costruire una retta tangente ad un arco o cerchio dal punto iniziale:

  1. Attivare l'opzione Vincolo di Tangente.
  2. Cliccare sull'arco o cerchio di riferimento.
  3. Muovendo il puntatore, il punto di partenza del segmento manterrà la condizione di tangente più vicina al punto cliccato.

Per costruire una retta tangente ad un arco o cerchio sul punto finale:

  1. Cliccare per definire il punto iniziale della retta.
  2. Attivare l'opzione Vincolo di Tangente.
  3. Cliccare sull'arco di riferimento o sul cerchio.

I vincoli di disegno e le opzioni di aggancio possono anche essere visualizzati come raggruppati in una finestra mobile in cui ci si può spostare in una posizione comoda sullo schermo. Per mostrare questa opzione, selezionare “Snap” nel menu Finestra.

Coordinate, Distanze e Angoli

I campi di input sono raggruppati al centro della barra di input: utilizzare questi campi per inserire i valori delle coordinate vincolate, della lunghezza e dell'angolo dell'oggetto che si sta disegnando. I campi X, Y e L supportano anche le somme di valori parziali.

Quando si fa clic su un campo o si utilizza la scorciatoia da tastiera, viene visualizzato un aiuto visivo per indicare il vincolo corrente.

In tutti i campi di immissione, i valori possono essere inseriti sia come numeri, ad es. come “100”, sia come somma di numeri, come “100+20+60”.

Coordinate X e Y

Le coordinate in HighDesign sono assolute o relative. Le coordinate assolute sono calcolate dal punto di origine globale del disegno e le coordinate relative sono calcolate dal punto precedente dell’oggetto che si sta disegnando.

Il punto di inserimento di un oggetto, cioè il suo punto di partenza, viene sempre impostato e visualizzato in coordinate assolute, con i valori X e Y calcolati dall'origine del foglio corrente. Il punto successivo è relativo per impostazione predefinita, ma è possibile modificarlo da relativo ad assoluto cliccando sull'icona X o Y nel campo di inserimento.

Per esempio, in una linea con punti a (20, 20) e (100, 100), il punto finale è (100, 100) in coordinate assolute e (80, 80) in coordinate relative.

Per impostare il punto di inserimento assoluto:

  1. Cliccare sul campo di inserimento corrispondente o premere i tasti “X” o “Y” della tastiera;
  2. Inserire la distanza X o Y desiderata dall'origine;
  3. Premere Invio per confermare.

Per impostare il punto finale relativo:

  1. Cliccare sui campi delle coordinate o premere i tasti “X” o “Y” sulla tastiera;
  2. Inserire la distanza dx o dy desiderata dal punto di partenza;
  3. Premere Invio per confermare.

È possibile passare dalle coordinate relative a quelle assolute e viceversa cliccando sull'icona X o Y nel campo di immissione o utilizzando le corrispondenti scorciatoie da tastiera.

Lunghezza Vincolata

È possibile vincolare un segmento, una linea o un raggio ad una lunghezza fissa dopo aver impostato il punto di partenza. In HighDesign, ci sono due metodi per vincolare una lunghezza che possono essere usati in modo intercambiabile.

A. Definire la direzione, impostare la lunghezza.

  1. Dopo aver impostato il punto di inserimento, spostare il puntatore con l'angolo desiderato del punto successivo;
  2. Inserire la lunghezza desiderata, sia come lunghezza totale che come somma di valori parziali;
  3. Premere Invio per confermare;

B. Definire la lunghezza, impostare la direzione.

  1. Cliccare sul campo Lunghezza o premere il tasto “L” sulla tastiera;
  2. Inserire la lunghezza desiderata;
  3. Premere Invio per confermare;
  4. Spostare il puntatore per impostare l'angolo del vettore.

Angolo Vincolato

Per costringere il movimento del puntatore ad un angolo fisso:

  1. Cliccare sul campo “A” (Angolo) o premere il tasto “A” sulla tastiera;
  2. Inserire il valore dell'angolo desiderato (in gradi);
  3. Premere Invio per confermare;
  4. Spostare il puntatore per impostare la lunghezza desiderata.

Angolo Relativo

È possibile vincolare il puntatore ad un angolo relativo rispetto ad una direzione di riferimento:

  1. Cliccare sul campo “A” o premere il tasto “A” sulla tastiera;
  2. Inserire il valore dell'angolo desiderato (non premere il tasto “ Invio);
  3. Cliccare sulla direzione di riferimento (linea, segmento di poli-linea o muro);
  4. Spostare il puntatore per impostare la lunghezza di destinazione.

Distanza Vincolata

Per impostare la distanza del punto di inserimento/inizio di un oggetto da un punto di riferimento, digitare il valore, premere Invio e fare clic sul punto di riferimento; la distanza viene ora visualizzata come raggio dal punto di riferimento: fare clic per impostare il punto di inserimento/inizio dell'oggetto.

Attivare i vincoli di disegno utilizzando il tasto TAB

I vincoli di disegno per le coordinate X e Y, Lunghezza e Angolo possono essere attivati anche premendo il tasto Tab della tastiera. Quando si preme quel tasto si attiva il vincolo X; poi, nell'ordine, Y, L, A. L'attivazione del vincolo Y memorizza gli eventuali valori inseriti nel campo X, in modo da facilitare l'impostazione delle coordinate di un punto.

Info Oggetto

Il pannello Info Oggetto fornisce un facile accesso alle coordinate e ad altri parametri geometrici e alle informazioni testuali degli oggetti selezionati. Se non sono selezionati oggetti grafici, il pannello Info Oggetto fornisce tutte le informazioni sul foglio corrente.

È possibile utilizzare questo pannello per leggere e modificare le coordinate di uno qualsiasi dei punti di controllo dell'oggetto, la larghezza, l'altezza, la lunghezza, l'angolo, ecc.

Inoltre, il pannello Info Oggetto è l'interfaccia principale per impostare il foglio corrente, il dettaglio o il layout: le diverse sezioni del pannello forniscono tutti i controlli e i campi necessari per impostare nome, scala, unità, dimensioni della pagina, opzioni grafiche e altre informazioni.

Esplorare il pannello Info Oggetto

Di norma, Info Oggetto modifica tutti gli oggetti selezionati dello stesso tipo. Per modificare solo l'oggetto corrente, i cui valori sono visualizzati sul pannello, aprire il menu a comparsa sull'intestazione del pannello e scegliere “Applica solo all'oggetto corrente”. Questa opzione rimane selezionata fino a quando non viene modificata di nuovo.

Il pannello è organizzato in sezioni distinte il cui numero dipende dal tipo di selezione.

Le sezioni per gli oggetti grafici sono:

  • Punto, disponibile per tutti gli oggetti grafici;
  • Geometria, per tutti gli oggetti grafici;
  • ID, per gli oggetti che hanno la loro finestra Impostazioni.

I Fogli correnti hanno le seguenti sezioni:

  • Foglio, disponibile per fogli di disegno, dettagli e layout;
  • Formato carta, disponibile per fogli di disegno e layout;
  • Impostazioni, per dettagli e layout;
  • Info, solo per i layout.

Quando si seleziona uno o più oggetti nel disegno, Info Oggetto visualizza immediatamente tutte le proprietà numeriche dell'ultimo oggetto selezionato. L'icona e il nome dell'oggetto corrente sono visualizzati sulla barra superiore della finestra, insieme alle frecce indietro e avanti usate per sfogliare gli oggetti nella selezione.

Alcuni oggetti come simboli, testi, dimensioni o muri hanno impostazioni speciali che non vengono visualizzate nel pannello Info Oggetto: quando uno di questi oggetti è selezionato è possibile aprire la sua finestra Impostazioni cliccando sull'icona nella barra superiore di Info Oggetto o tramite il pulsante Mostra Impostazioni nella sezione ID.

Punto

La sezione Punto visualizza le coordinate X, Y del punto corrente. Il punto corrente è evidenziato nel disegno, ed è possibile utilizzare i pulsanti indietro e avanti per scorrere i punti notevoli dell'oggetto. Per modificare un valore, fare clic sul campo, inserire il nuovo valore e premere il tasto Invio sulla tastiera.

A seconda del tipo di oggetto e del punto attivo, l'azione risultante della modifica delle coordinate del punto attivo può essere un tratto o uno spostamento. Per esempio, se si modifica il Punto 2 di una retta, questo viene allungato; se si modifica il Punto 3 di un cerchio (il suo centro), l'azione è uno spostamento.

Quando si seleziona un rettangolo o un poligono, questa sezione mostra il tipo di trasformazione compatibile con il punto attivo corrente. Con le poli-linee è possibile modificare la convessità del segmento descritto dal punto attivo.

Geometria

La sezione Geometria visualizza i valori che descrivono le dimensioni e l'orientamento dell'oggetto, come larghezza, altezza, raggio, lunghezza, angolo, ecc. Campi come Larghezza e Altezza possono essere collegati per limitare le proporzioni dell'oggetto.

Questa sezione visualizza anche valori di sola lettura che sono calcolati in base alle coordinate e alle dimensioni correnti, come il perimetro e l'area.

Alcuni oggetti, come le quote e i percorsi di misura, visualizzano il loro valore esclusivamente in un campo di sola lettura, dato che in realtà dipendono da altri oggetti per le loro dimensioni. I muri aggiungono alcuni controlli per veloci modifiche di costruzione.

ID

Questa sezione è specifica per quegli oggetti che hanno la finestra Impostazioni e mostra informazioni testuali. Qui è possibile impostare il nome, il tag o aggiungere informazioni personalizzate alla selezione.

Questa sezione fornisce anche il pulsante per aprire la finestra Impostazioni dell'oggetto.

Zoom e Posizione Quadro

Questi strumenti di visualizzazione, per impostazione predefinita raggruppati in un pratico dock sul bordo dell'area di disegno, sono essenziali per la gestione dei disegni. La prima volta che si lancia HighDesign, Posizione Quadro, Zoom e Zoom all’Area Visibile sono raggruppati come pulsanti semitrasparenti nell'angolo in alto a destra dell'area di disegno: cliccando con il tasto destro del mouse sul dock è possibile aprire un menu con le opzioni per modificarne la posizione.

Inoltre, nella sezione Zoom e Scorrimento del riquadro dell'area di lavoro delle Preferenze di HighDesign è possibile aprire il menu “Visualizza controlli” per modificare la posizione del dock o per visualizzare i controlli nella barra principale degli strumenti.

Posizione Quadro

Utilizzare questo strumento per trascinare l'area di disegno e spostare rapidamente la vista corrente. Per utilizzare lo strumento Posizione Quadro fare clic e trascinare il puntatore del mouse. Fare doppio clic sull'icona dello strumento per impostare la vista al centro del disegno.

Lo strumento di posizione quadro può anche essere attivato temporaneamente con qualsiasi strumento premendo la barra spaziatrice della tastiera: se avete già iniziato un'attività, ad esempio il disegno di una linea, l'uso dello strumento di panning non interferirà con la funzione corrente.

Con un mouse a più tasti è possibile eseguire il pan del disegno cliccando il pulsante centrale / rotella e trascinando il puntatore.

Zoom

Lo strumento Zoom consente di ingrandire o ridurre la vista corrente del disegno ingrandendo o riducendo lo zoom.

Cliccare sul punto di partenza, quindi spostare il puntatore e cliccare nuovamente sulla definizione dell'area rettangolare che verrà ingrandita. Tenere premuto il tasto Opzione per ingrandire o ridurre.

Il fattore di zoom è inversamente proporzionale alla dimensione del rettangolo di zoom, cioè più piccolo è il rettangolo, più alto sarà il fattore.

Fare doppio clic sull'icona dello strumento per impostare di nuovo il fattore di visualizzazione al 100% (vista effettiva).

Altri comandi di zoom sono raggruppati nel menu View, tra cui “Zoom all’Area Visibile”, “Zoom In” e “Zoom Out”.

Lo zoom dinamico è abilitato premendo i tasti “cmd e +” o “cmd e -” sulla tastiera o, con un mouse a più tasti, ruotando la rotella: ruotare la rotella in avanti per ingrandire e indietro per ridurre. Anche i gesti del Trackpad sono supportati dallo zoom dinamico.

Zoom all’Area Visibile

Questo controllo di visualizzazione è disponibile anche come pulsante nel dock degli strumenti di visualizzazione: facendo clic su questo pulsante il fattore di zoom e il centro della vista vengono regolati per adattarsi alle estensioni dell'area di disegno. In questo modo si ottiene una vista panoramica di tutto il disegno visibile.

Quando uno o più oggetti sono selezionati, questo controllo centra la vista della sola selezione.

Impostare gli Attributi Grafici

La maggior parte degli attributi comuni a tutti i tipi di oggetto possono essere impostati e modificati nella Barra delle Proprietà. Le proprietà che sono condivise tra la maggior parte dei tipi di oggetto sono: livello, colore della penna, colore del riempimento, tipi di linee della penna, marcatori di inizio e fine, spessore della penna.

Per impostare gli attributi per i nuovi oggetti, assicurarsi che nessun oggetto sia selezionato e quindi utilizzare i controlli della barra delle proprietà. Per modificare le proprietà di un oggetto, selezionarlo e quindi modificare i valori corrispondenti.

Le proprietà grafiche specifiche di alcuni oggetti, come le linee di estensione delle dimensioni o i tratteggi e il colore di riempimento delle pareti, vengono gestite attraverso la loro finestra Impostazioni.

Lucidi

Usare il menu a comparsa Lucidi nella barra delle Proprietà della finestra principale per impostare il livello corrente e cambiare il lucido alle voci selezionate. A sinistra del nome del lucido ci sono le icone del colore, della visibilità e degli attributi di blocco: fare clic su di esse per modificare tali attributi.

Per cambiare il lucido di un elemento, selezionarlo e scegliere il nuovo lucido dal menu a comparsa Lucidi. Attraverso questo menu è anche possibile creare un nuovo lucido, aprire il pannello Lucidi della finestra Gestione Risorse e mascherare gli altri lucidi per mantenere visibile solo il lucido attualmente selezionato.

Colore della Penna

Utilizzare il menu a comparsa Colore Penna per selezionare il colore corrente della penna o cambiare il colore degli elementi selezionati. Il colore della penna controlla il colore del contorno degli oggetti.

È possibile scegliere un colore della penna da una tavolozza di 256 colori indicizzati; utilizzare il colore del livello corrente con l'opzione Dal lucido; impostare un colore di contrasto o non impostare alcun colore. Quando l'opzione “Dal Lucido” è attivata, il colore corrente è quello del lucido corrente. Con l'opzione “Colore per contrasto” il colore viene automaticamente impostato sullo schermo come bianco con sfondi scuri o nero con sfondi chiari (invariabilmente nero sulle stampe).

Colore del Riempimento

Il menu a comparsa del colore del riempimento controlla le opzioni per il riempimento di una forma con il colore. Il pulsante è attivo solo per gli oggetti con la proprietà di riempimento, come linee poligonali, poligoni, riempimenti, archi, cerchi ed ellissi e pareti.

Le opzioni disponibili sono:

  • La tavolozza di 256 colori indicizzati con opacità regolabile, che varia dallo 0%, completamente trasparente, al 100%, completamente opaco.
  • Pulsante “Nessun Colore”.
  • Selezione dei colori del Sistema. * Gradiente. Utilizzare questo pulsante per passare dal colore pieno al gradiente.

Controllo Gradiente (solo per Mac)

Il tasto del gradiente nel menu Riempimento apre la finestra di controllo dei gradienti. Un gradiente è un riempimento che varia il suo colore da un colore iniziale a un colore finale, con opacità variabile. I tipi di gradiente disponibili sono lineari (o assiali) e radiali, e possono essere attivati attraverso i pulsanti in alto a sinistra della finestra.

Accanto ai pulsanti di tipo è presente il pulsante Inverti Colori, che inverte i colori nel regolatore di gradiente.

Il selezionatore Angolo e il campo controllano l'angolo tra i punti di inizio e fine del gradiente.

Il regolatore Colore controlla i colori e la loro posizione lungo l'asse. Fare clic su un colore per aprire il menu dei colori e regolarne l'opacità; fare clic sul regolatore per aggiungere un colore; trascinare un colore lungo il regolatore per cambiarne la posizione; trascinare il colore in verticale per rimuoverlo.

Per impostazione predefinita, le modifiche sono visibili in tempo reale. A seconda della complessità del progetto, è possibile fare clic sulla casella di controllo Mostra Anteprima per disattivare l'anteprima dal vivo.

La geometria di un gradiente, cioè la posizione dei punti finali e il raggio dei cerchi, può essere modificata selezionando un oggetto con un gradiente e regolando i punti sullo schermo.

Gradiente Lineare

Un gradiente lineare è un'interpolazione di colore che varia lungo una linea tra due punti definiti. Quando si seleziona un oggetto con un gradiente lineare, una linea con due punti finali contrassegna il gradiente lineare. È possibile modificare ogni punto e regolare il gradiente secondo necessità.

Gradiente Radiale

Un gradiente radiale è un riempimento che varia lungo un asse tra due cerchi. In un oggetto selezionato, viene visualizzato un gradiente radiale con due cerchi, tipicamente di dimensioni diverse. Il secondo cerchio, corrispondente al colore finale, deve sempre essere contenuto all'interno del primo cerchio. I punti iniziali sono contrassegnati con un maniglia quadrata e i punti finali con un maniglia rotonda.

NOTA - A causa del motore grafico utilizzato, i colori del gradiente con opacità variabile non possono essere stampati o salvati in formato PDF. Su stampa o PDF, tali gradienti vengono catturati con un valore di opacità del 100%. I gradienti trasparenti possono essere esportati in un formato immagine come TIFF, PNG o JPEG.

Tipi di Linea

Usare il menu a comparsa Tipo di Linea per impostare il tipo di linea corrente o modificare le voci selezionate (se applicabile). Questo menu a comparsa elenca tutti i tipi di linea attualmente caricati, ciascuno con il proprio numero di indice.

Il menu Tipo di Linea fornisce anche l'opzione di aprire il pannello Tipo di Linea della finestra Gestione Risorse per gestire i tipi di linea esistenti o per crearne di nuovi.

Frecce e Marcatori

I vertici degli oggetti, come linee, poli-linee, ovali, ecc. possono avere frecce e altri marcatori.

Per impostare o modificare il marcatore di oggetto corrente, utilizzare i due menu a comparsa del marcatore: quello di sinistra controlla il punto iniziale di un oggetto (Freccia iniziale), e quello di destra controlla i punti finali (Freccia finale).

Un controllo in fondo al menu permette di impostare la dimensione della punta della freccia.

Spessori delle Penne

Utilizzare questo menu a comparsa per impostare e modificare lo spessore attuale della penna da un elenco di 22 valori diversi, espressi in millimetri.

Per modificare lo spessore di una elemento, selezionarlo e scegliere il nuovo spessore dal menu.

A causa della risoluzione dello schermo (72 dpi), gli spessori delle penne non possono essere visualizzati sullo schermo esattamente come appaiono sulle stampe; quando è attiva la modalità Spessore penna effettivo (dimensione di stampa), HighDesign visualizza le diverse penne sullo schermo con un'approssimazione alla loro reale dimensione di stampa. Quando la modalità Bitmap è attiva, gli spessori delle penne vengono visualizzati con una semplice dimensione progressiva di pixel.

Per modificare il modo in cui sono visualizzati gli spessori delle penne sullo schermo, aprire la finestra delle Preferenze di HighDesign, selezionare il pannello Disegno e scegliere una delle tre opzioni disponibili per gli spessori delle penne o fare clic sul pulsante in basso a destra della finestra principale.

Nelle stampe con carta di bassa qualità, gli spessori delle penne possono essere un po' diversi da quelli scelti nel menu. La risoluzione di stampa ottimale è di 600 dpi su carta di alta qualità.

Copiare le Proprietà

Con questo comando tutte le proprietà dell'elemento selezionato vengono copiate e memorizzate per un uso successivo. Questa funzione si applica a lucido, colore, tipo di linea, spessore e punte di freccia. Le proprietà copiate possono poi essere applicate ad altri elementi del disegno.

Questo strumento può essere utilizzato anche tramite un equivalente da tastiera: Opzione-click su un elemento per attivarlo.

Incollare le Proprietà

Questo comando consente di applicare le proprietà precedentemente copiate a tutti gli elementi su cui si clicca. Quando il puntatore si trova sopra un elemento, il cursore si trasforma in un secchio di vernice: cliccate per applicare le proprietà a quell'elemento. Fare clic in una regione vuota per uscire dallo strumento Incolla Proprietà.

Questo strumento può essere utilizzato anche tramite un equivalente da tastiera: Command-Opzione-click su un elemento per attivarlo.

Stili e Tipi (Pro)

Definizione di Stili e Tipi

Uno stile è un insieme predefinito di informazioni, proprietà e comportamenti che è possibile applicare agli oggetti grafici o agli elementi architettonici: quando applichiamo queste preimpostazioni agli oggetti di disegno abbiamo Stili Grafici, mentre quando applichiamo un insieme predefinito ad un elemento architettonico creiamo un Tipo di Elemento Costruttivo.

Gli stili e i tipi definiscono le proprietà comuni di una certa classe di oggetti grafici o elementi edilizi. Le specifiche definite da uno stile o da un tipo vengono applicate a tutte le occorrenze di quella classe nel progetto.

Stli Grafici

Uno stile grafico memorizza le impostazioni correnti di Lucido, Colore della Penna e del Riempimento, Punte di freccia, Tipo di linea e Spessore della penna: può anche includere le impostazioni specifiche di una classe di oggetti.

Gli stili grafici sono classificati come:

- Stili di Base. Questi sono stili generici e possono essere applicati a semplici oggetti di disegno, inclusi oggetti di costruzione, linee, poli-linee, rettangoli e poligoni, archi, cerchi ed ellissi e curve: gli stili di base esistenti possono anche essere caricati da tipi di elementi di costruzione come proprietà grafiche predefinite. Le proprietà che non sono supportate in una classe di oggetti vengono ignorate (p.e. la proprietà del colore di riempimento viene ignorata dalle linee).

- Stili Specifici, che si applicano solo a specifici oggetti di disegno con le proprie impostazioni degli strumenti; questi stili sono collegati agli oggetti per i quali sono stati creati: quando si seleziona uno stile specifico, si attivano lo strumento e il metodo corrispondente. Gli stili specifici includono anche tutte le impostazioni specifiche del loro strumento: ad esempio, se si crea uno stile di testo, esso memorizza le impostazioni correnti dello strumento Testo, come il carattere, la dimensione, l'allineamento, ecc.

Tipi di Elementi Costruttivi

Gli elementi architettonici come muri, colonne, porte e finestre possono ricevere insiemi predefiniti di informazioni, proprietà grafiche e impostazioni specifiche degli elementi: questi modelli che si applicano ai nuovi elementi o agli elementi selezionati sono chiamati Tipi di Elementi Costruttivi.

Un tipo di elemento edilizio memorizza informazioni come nome, tag e descrizione, proprietà grafiche opzionali che possono essere caricate da uno stile di base esistente e le impostazioni (geometria e opzioni) dell'elemento corrente.

Gestire gli Stili

Il pannello Stili e Tipi di Gestione Risorse è la finestra di dialogo principale per gestire gli stili e i tipi salvati: utilizzare questo pannello per aggiungere al progetto gli stili selezionati dalla Libreria HighDesign o dalla Libreria utente; questo pannello fornisce anche i comandi per creare, duplicare, modificare ed eliminare gli stili.

Gli stili relativi al progetto corrente sono gestiti tramite il pannello Stili del Progetto.

Pannello Stili di Progetto

Gli Styles del progetto possono essere creati e gestiti velocemente attraverso il pannello Stili del Progetto: è possibile consultare e gestire gli stili grafici e i tipi di elementi del progetto, crearne di nuovi e rimuovere gli stili dal progetto.

Questo pannello contrassegna gli oggetti selezionati o lo strumento corrente senza stile come ” No Stile“ in alto ed elenca tutti gli stili grafici e i tipi di elementi del progetto disponibili: lo stile corrente è evidenziato in questo elenco.

I comandi principali del pannello sono raggruppati come pulsanti nella parte inferiore del pannello:

  • Per creare un nuovo stile premere il pulsante “Aggiungi”;
  • Per rimuovere lo stile corrente dal progetto premere il pulsante “Meno”;
  • L'icona Aggiungi a destra del titolo della sezione Stile Grafico apre la finestra Nuovo Stile Grafico, mentre l'icona Aggiungi a destra del titolo della sezione Tipo di Elemento di Costruzione apre la finestra Nuovo Tipo di Elemento di Costruzione.

È anche possibile aprire un menu a tendina cliccando sul triangolo a destra del nome di uno stile per ottenere alcune opzioni dello stile corrente.

Le opzioni disponibili del menu a tendina sono:

  • Duplicare lo Stile/Tipo;
  • Modifica Stile/Tipo….;
  • Ritorno allo Stile/Tipo originale;
  • Seleziona tutti gli usi di ” Stile/tipo corrente“;
  • Rimuovi dal progetto.

Finestre Nuovo Stile e Nuovo Tipo

Le finestre Nuovo Stile e Nuovo Tipo mostrano uno o più pannelli disposti in diverse sezioni. Il primo pannello mostra la sezione Identità, che permette di impostare le informazioni specifiche per la classe di oggetti selezionata, e la sezione Proprietà Grafiche per impostare le proprietà generali che sono disponibili anche nella Barra delle proprietà.

I pannelli aggiuntivi della finestra possono cambiare, a seconda della classe selezionata, e presentare le sezioni di impostazione specifiche per la classe di oggetti corrente.

Creare un Nuovo Stile Grafico

La finestra Nuovo Stile può essere una finestra a singolo pannello se la classe di oggetti selezionata non ha la sua finestra Impostazioni: in questo caso il nuovo stile grafico è un Stile di Base che memorizza solo il nome e le proprietà grafiche generali (Lucido, Colore del Tratto, Colore del Riempimento, Tipo di Linea, Marcatori e Spessore della Penna); queste proprietà sono opzionali ed è possibile ad esempio creare uno stile grafico con solo il nome, il lucido ed il colore del tratto. Uno stile di base è uno stile generale e può essere applicato a tutti gli oggetti grafici.

Se la classe di oggetti selezionata include impostazioni specifiche dello strumento, la finestra Nuovo Stile è organizzata in pannelli corrispondenti alle sezioni della finestra Impostazioni dello strumento: questo stile grafico è uno Stile Specifico e memorizza le proprietà grafiche generali e tutte le impostazioni e le opzioni appartenenti alla classe corrente.

Nella sezione Identità della finestra Nuovo Stile è possibile inserire il nome dello stile e selezionare la posizione del nuovo stile:

  • “Solo questo progetto” - selezionando questa opzione il nuovo stile esiste solo nel progetto corrente;
  • “Libreria utente” - questa opzione salva lo stile come file nella cartella Libreria Utente su disco ed anche nel progetto corrente.

Una volta creato, il nuovo stile viene aggiunto alla lista della sezione Stili Grafici del pannello Stili del Progetto del progetto corrente. Selezionarlo per disegnare nuovi oggetti con quello stile (questi oggetti sono chiamati occorrenze dello stile selezionato). Se lo stile è uno Stile Specifico, si attivano lo strumento ed il metodo corrispondente.

Per applicare uno stile ad uno o più oggetti, selezionare gli oggetti e fare clic sul nome dello stile nel pannello Stili del Progetto.

Creare un Nuovo Tipo di Elemento Costruttivo

La finestra Nuovo Tipo visualizza più opzioni nella sezione Identità con i campi per inserire il Nome del Tipo, il Tag e la Descrizione.

Inoltre, la sezione Proprietà Grafiche è opzionale e può essere attivata cliccando l'interruttore vicino al titolo della sezione. Quando questa sezione è attiva, è possibile caricare uno stile di base esistente attraverso il menu Stile Grafico ed estrarne le proprietà grafiche.

I pannelli della finestra Nuovo Tipo visualizzano le sezioni di impostazione specifiche della classe attuale degli elementi architettonici: muro, colonna, porta o finestra.

I nuovi tipi vengono aggiunti all'elenco della sezione Tipi di Elementi Costruttivi del pannello Stili di Progetto del progetto corrente e possono anche essere salvati nella cartella Libreria Utente.

Modificare uno Stile o Tipo

Per modificare le impostazioni di uno stile, come il nome, le proprietà grafiche o le impostazioni specifiche degli elementi, selezionarlo nel pannello Stili del Progetto e scegliere “Modifica Stile” o “Modifica Tipo” dal menu a tendina per aprire la finestra Modifica Stile o Modifica Tipo.

Questa finestra si differenzia dalla finestra Nuovo Stile/Tipo per alcuni dettagli: non è possibile selezionare la posizione dello stile e tutti i campi e le opzioni mostrano le impostazioni dello stile selezionato.

Tutte le modifiche apportate ad uno stile aggiornano automaticamente tutte le occorrenze di quello stile nel progetto. Se un'occorrenza di uno stile viene modificata, quando viene selezionata viene contrassegnata come modificata nel pannello Stili del Progetto. Non è possibile aggiornare o creare uno Stile o un Tipo mediante selezione.

Ripristinare uno Stile

Quando un'occorrenza dello stile corrente è stata temporaneamente modificata modificando una delle sue proprietà grafiche o impostazioni, è possibile riportarla alle impostazioni originali scegliendo ” Ripristina lo Stile Originale“ dal menu a tendina del pannello Stili del Progetto.

Trovare tutti gli usi di uno Stile o di un Tipo

Nel pannello Stili del Progetto aprire il menu a tendina dello stile o del tipo e scegliere “Seleziona Tutti gli Usi di [nome dello stile/tipo]”. Vengono così selezionate tutte le istanze di quello stile sul foglio corrente.

Rimuovere uno Stile o un Tipo dal Progetto

Selezionare lo stile o il tipo nel pannello Stili di Progetto e fare clic sul pulsante “Rimuovi dal Progetto” (-), oppure scegliere “Elimina Stile/Tipo” dal menu a tendina.

Se ci sono delle occorrenze di quello stile nel progetto, una finestra di dialogo permette di scegliere l'opzione “Nessuno Stile” o un nuovo stile compatibile per sostituire quello che si sta rimuovendo. Gli oggetti il cui stile viene sostituito vengono aggiornati per corrispondere al nuovo stile.

/usr/www/users/ilexsoft/help.ilexsoft.com/data/pages/it/guides/highdesign-r6/tecniche-essenziali.txt · Last modified: 2021/01/30 07:09 by ilexsoft