You are here: start » it » guides » highdesign-r6 » strumenti-avanzati

9 Strumenti Avanzati

9 Strumenti Avanzati

  • Viste di Progetto (Pro)
  • Fotogrammetria (Pro)
  • Modifica Immagini (Pro)
  • Presentazione dei Disegni (Pro)

Viste di Progetto

In HighDesign Pro una Vista di Progetto è un modo alternativo per creare presentazioni pronte per la stampa: attraverso il pannello Viste di Progetto è possibile creare nuove viste del progetto e sfogliare le viste esistenti.

Una vista di progetto memorizza lo stato di visibilità dei fogli e dei lucidi correnti e permette di creare ad esempio una “tavola” di un pianta con dimensioni e superfici e un'altra “tavola” della stessa pianta (foglio) con i soli servizi.

Grazie all'opzione di trasparenza dei fogli di disegno e alla combinazione di fogli e lucidi visibili è possibile creare viste di progetto complesse per le proprie stampe: nella finestra Stampa è possibile selezionare la Vista di Progetto che si desidera stampare attraverso il menu Viste.

Gestione Viste

Il pannello “Viste” fornisce un elenco di tutte le viste di progetto salvate. Un'anteprima in tempo reale delle viste appare quando il puntatore è sopra il nome di una vista. Cliccare sul nome di una vista per attivarla o fare doppio clic per rinominarla.

Per aggiungere una vista, cliccare sul pulsante “Salva vista corrente” e digitare un nome: le viste salvate includono la posizione, il fattore di ingrandimento e i fogli e i lucidi visibili.

Per cancellare la vista attualmente selezionata, cliccare sul pulsante “Cancella vista”.

Il pulsante Aggiorna Vista ridefinisce la vista selezionata dalle impostazioni correnti.

Fotogrammetria

Introduzione

HighDesign Pro fornisce un potente strumento di fotogrammetria ad immagine singola per ottenere la proiezione effettiva degli elementi architettonici catturati in un'immagine: questa funzione può essere utilizzata per il rilievo di facciate architettoniche e di qualsiasi superficie planare e richiede solo una normale macchina fotografica e due misure. Non sono necessarie attrezzature specifiche né conoscenze specifiche.

La fotogrammetria in HighDesign offre due metodi diversi:

  1. Correzione dell'Immagine: trasforma l'immagine originale rettificando la deformazione prospettica.
  2. Tracciatura Prospettica: crea una proiezione corretta tracciando gli elementi nell'immagine dopo che la geometria interna dell'immagine è stata impostata. Tutte le proiezioni sono vettoriali.

Ecco alcuni requisiti e suggerimenti per ottenere i migliori risultati:

  • L'immagine deve includere almeno due elementi orizzontali e due verticali (ad esempio una porta, una finestra, un muro di mattoni) e, se disponibili ma non strettamente necessari, due elementi con la terza dimensione. Questi requisiti sono gli unici realmente necessari per utilizzare lo strumento di fotogrammetria in HighDesign.
  • Se possibile, evitare viste troppo angolate perché la proiezione potrebbe essere deformata ai margini dell'immagine;
  • Per lo stesso motivo di cui sopra, evitare le lenti fisheye (<28 mm);
  • L'immagine dovrebbe includere almeno una dimensione orizzontale ed una verticale; tuttavia, se non si hanno queste dimensioni, è possibile impostare la proiezione con qualsiasi dimensione e successivamente ridimensionare il disegno risultante.

Come regola generale, assicurarsi che l'immagine includa alcuni elementi di riferimento e che non sia stata ritagliata o deformata. Quando la terza direzione (profondità) non è disponibile, la geometria interna della vista si basa sulle diagonali del rettangolo dell'immagine, da qui l'importanza di preservare la forma originale dell'immagine.

Impostare i Dati Richiesti

Il processo di configurazione è molto semplice e non richiede alcuna conoscenza specifica.

Per avviare una fotogrammetria, selezionare Strumenti Fotogrammetria. HighDesign passa all'ambiente di lavoro della Fotogrammetria, con la finestra di impostazione della Fotogrammetria, uno sfondo grigio e un set limitato di strumenti di disegno:

  • Freccia;
  • Oggetti di costruzione;
  • Linee;
  • Poli-linee con segmenti rettilinei;
  • Tratteggi;
  • Curve;
  • Strumenti di visualizzazione (Posizione quadro, Zoom e Misura).

PASSO 1: selezionare l'immagine

Premere il pulsante “ Scegli…” e selezionare il file immagine da aprire. I tipi di file supportati sono: TIFF, PNG, JPEG.

Cliccare il pulsante “Avanti”: l'immagine viene ora visualizzata sullo schermo e la finestra di impostazione della Fotogrammetria cambia.

PASSO 2: definire la geometria interna

Aperta l'immagine, selezionare il tipo geometrico dai pulsanti:

  • Tutte e tre le direzioni X, Y e Z sono visibili nell'immagine: ci sono almeno due linee orizzontali, due verticali e due per la profondità;
  • Sono visibili le due direzioni X e Y. L'immagine mostra almeno due linee orizzontali e due verticali, ma non è visibile alcuna linea di profondità; questo tipo comprende le immagini scattate con l'obiettivo parallelo alla superficie e le scansioni di piante.
  • Il valore della lunghezza focale è opzionale.

In questo caso abbiamo selezionato la prima opzione, con le linee di profondità chiaramente visibili nell'immagine. Una griglia quadrata e due linee di profondità blu sono visualizzate sopra l'immagine. La procedura è la seguente:

  1. Trascinare la griglia per le maniglie sui suoi vertici in modo che corrisponda alle linee di riferimento orizzontali e verticali dell'immagine come davanzali, stipiti di porte e finestre e cornici;
  2. Trascinare le due linee di profondità blu per i loro estremi per farle corrispondere alle linee di riferimento della profondità sull'immagine;
  3. È possibile adattare la griglia e le linee di profondità tenendo presente che di solito le linee lontane dal centro dell'immagine hanno una deformazione che dipende dalla qualità e dalla lunghezza focale dell'obiettivo usato;
  4. Premere il pulsante “Avanti” per passare alla fase successiva di impostazione.

PASSO 3: definire le misure conosciute

Due linee, una verde verticale ed una rossa orizzontale, sono visualizzate sopra l'immagine. Queste linee, disegnate nella vista prospettica corrispondente alla geometria interna dell'immagine, saranno utilizzate per inserire le due misure note.

  1. Trascinare la linea verticale sulla dimensione nota, in questo caso lo stipite della porta ad arco, e allungarla/accorciarla per i punti finali fino a farla corrispondere all'oggetto conosciuto: inserire la misura verticale nota nel campo corrispondente della finestra mobile di impostazione e selezionare le unità di disegno.
  2. Trascinare la linea orizzontale sull'oggetto conosciuto, il davanzale della porta, regolarla fino a farla corrispondere alla dimensione conosciuta ed inserire la misura effettiva nel campo corrispondente ed impostare la scala di disegno della proiezione.

PASSO 4: scegliere la modalità di proiezione

La configurazione è ora completa ed è possibile scegliere la modalità di proiezione tra la deformazione dell'immagine e la proiezione vettoriale. Scegliendo la deformazione dell'immagine l'immagine sarà stirata per correggere la deformazione prospettica e corrispondere alle proporzioni date: l'immagine risultante potrebbe quindi dover essere ridimensionata per adattarsi alle misure note.

La seconda opzione, “Ricalca e Proietta ”, consiste nel ricalcare tutti gli oggetti dell'immagine che si desidera rilevare per ottenere la proiezione alla scala di disegno desiderata.

Disegnare e Visualizzare gli Elementi Proiettati

Come già detto, l'area di lavoro dello strumento di fotogrammetria fornisce una serie limitata di strumenti di disegno e tre fogli sono elencati nella Barra Laterale:

  • “Foglio 1”, il foglio creato automaticamente quando si lancia HighDesign;
  • “Fotogrammetria”, che memorizza l'immagine e tutti i dati di impostazione e questo è il foglio che si usa per ricalcare tutti gli oggetti da proiettare;
  • “Proiezione”, che viene visualizzata come una finestra mobile quando si è sul foglio “Fotogrammetria”.

Inoltre, l'ambiente “Proiezione” ha le seguenti caratteristiche:

  • Le direzioni sono vincolate ai punti di fuga; tenendo premuto il tasto Shift mentre si disegnano o si ricalcano le linee, le direzioni sono vincolate al punto di fuga più vicino, verticale o orizzontale.
  • La finestra di Proiezione visualizza il risultato di tutte le proiezioni, cioè tutti gli elementi disegnati all'interno dell'ambiente di Fotogrammetria sono proiettati in tempo reale alla scala di disegno precedentemente impostata.

Il foglio “Proiezione”, come tutti i fogli di disegno, può essere utilizzato per disegnare, modificare, salvare ed esportare la proiezione come un disegno separato.

Elementi del menu Strumenti

Questi comandi sono utilizzati all'interno dello strumento di fotogrammetria e consentono di gestire alcune importanti funzioni:

  • “Fotogrammetria”: utilizzato per avviare una nuova proiezione fotogrammetrica o per riprendere quella corrente.
  • “Ripristina Fotogrammetria”: cancella tutti i settaggi (geometria e dimensioni note) e riporta il processo di fotogrammetria alla fase di impostazione; la finestra di impostazione si apre di nuovo e tutti gli elementi proiettati vengono rimossi. Si prega di prestare attenzione quando si utilizza questo comando in quanto non è annullabile.
  • “Chiudi Fotogrammetria”: nasconde l'immagine dal progetto e mette in pausa l'ambiente di fotogrammetria cambiando ambiente di lavoro in Progetto. Gli elementi disegnati sul foglio corrente non vengono cancellati; selezionare “Fotogrammetria” per riprendere la fotogrammetria.

Modificare le Immagini

HighDesign consente di inserire immagini in un progetto e di trattarle come qualsiasi altro oggetto vettoriale: così come si può cambiare il colore e il tipo di linea di un oggetto, si possono modificare anche le immagini.

Succede molto spesso di avere la necessità di regolare la luminosità, il contrasto, i livelli di colore di un'immagine da utilizzare per una proiezione fotogrammetrica o come sfondo per un disegno: HighDesign fornisce un modulo integrato di elaborazione delle immagini per applicare rapidamente molti miglioramenti all'immagine.

Questo strumento permette di modificare l'intera immagine o solo una parte di essa applicando trasformazioni di pixel e filtri. Se avete bisogno di ruotare o ridimensionare un'immagine, utilizzate le funzioni standard Disegno Ruota o Disegno Ridimensiona.

Per modificare le dimensioni sullo schermo, le dimensioni di stampa, la risoluzione e la trasparenza dell'immagine selezionata, utilizzate la finestra Impostazioni Immagine sul menu Modifica Finestra Impostazioni Immagine.

Applicare Filtri ad una Immagine

Selezionare un'immagine, quindi scegliere Strumenti ▸ Modifica Immagine: si apre una finestra con tutti i controlli per modificare l'immagine selezionata. La finestra di dialogo Modifica Immagine mostra l'anteprima dell'immagine in alto. I controlli sono raggruppati come pulsanti di trasformazione, pulsanti dei filtri avanzati e i controlli per la luminosità, il contrasto e la saturazione. Le opzioni disponibili sono:

Trasformazione

  • Specchia Orizzontale, rispecchia l'immagine orizzontalmente sul suo asse Y;
  • Specchia Verticale, rispecchia l'immagine verticalmente sul suo asse X;
  • Ritaglia, taglia i bordi dell'immagine lasciando solo l'area selezionata.

Messa a Fuoco e Colori

  • Scala di grigi, cambia tutti i colori in grigio;
  • Inverti, inverte tutti i colori da positivi a negativi e viceversa;
  • Nitidezza, migliora il contrasto sui bordi;
  • Sfocatura, attenua l'immagine;
  • Luminosità, controlla la quantità di luce nell'immagine;
  • Contrasto, regola il contrasto tra i colori;
  • Saturazione, aumenta la saturazione del colore.

Per applicare un filtro, premere il pulsante corrispondente o spostare il cursore. I filtri di nitidezza e sfocatura possono essere applicati più volte. Qualsiasi filtro applicato, che si può vedere in anteprima nella miniatura, viene memorizzato in un'immagine temporanea fino a quando non si preme il pulsante “Applica”, che applica tutti i filtri in coda all'immagine principale, mentre il pulsante “Annulla” cancella la coda dei filtri.

Il pulsante “Ripristina Immagine”, nell'angolo in basso a sinistra della finestra, cancella tutti i filtri applicati dall'immagine.

Presentazione dei Disegni

Si tratta di uno strumento di rendering 2D che crea immagini di alta qualità del vostro progetto con vari effetti di sfondo, colori di penna e di riempimento, bordi e margini, filigrana e dimensioni e risoluzione regolabili.

Questo strumento non solo applica l'anti-aliasing ai bordi degli oggetti, ma permette anche di personalizzare le dimensioni di stampa e la risoluzione dell'immagine e fornisce opzioni di sfondo, cornici ed effetti di colore per fare presentazioni di grande impatto dei vostri progetti. Il risultato è un'immagine che può essere esportata in uno qualsiasi dei formati di file grafici supportati. Per impostare tutte le opzioni, selezionare Strumenti Presentazione Disegno per aprire la finestra di dialogo delle impostazioni dell'immagine.

Impostare le Opzioni dell'Immagine

Utilizzare questa finestra di dialogo per impostare gli effetti visivi e le opzioni per creare un'illustrazione.

  1. Effetti immagine: fare clic per visualizzare le opzioni grafiche.
  2. Bordo: opzione per visualizzare un bordo, il colore e lo spessore del margine.
  3. Filigrana: opzioni per aggiungere una firma digitale o una filigrana all'immagine.
  4. Dimensione immagine: opzioni per impostare la risoluzione e la dimensione dell'immagine.
  5. Anteprima dell'immagine risultante.
  6. Pulsanti per salvare le impostazioni correnti come nuovo tema o per cancellare il tema selezionato.
  7. Elenco dei temi caricati.

Una volta fatte tutte le impostazioni, se si desidera salvare le impostazioni attuali come nuovo tema per un uso futuro, basta premere il pulsante “+” vicino al menu dei temi per vederlo elencato nel menu con il nome desiderato. Cliccate su “Ok” per confermare e aprire una nuova finestra con l'immagine risultante o su “Annulla” per chiudere questa finestra.

Effetti dell'Immagine

Le opzioni per applicare effetti grafici all'immagine includono:

- Sfondo

  • Dal Progetto: imposta lo sfondo dello stesso colore utilizzato nella finestra principale del progetto;
  • Colore Uniforme: utilizzare il pulsante per selezionare il colore;
  • Gradiente Orizzontale: selezionare i colori a sinistra e a destra del gradiente;
  • Gradiente Verticale: selezionare i colori superiore e inferiore del gradiente;
  • Immagine, piastrellata: disegna un'immagine come sfondo; le immagini più piccole dell'immagine di destinazione sono piastrellate; selezionare l'immagine dal disco;
  • Immagine, ridimensionata: disegna un'immagine come sfondo scalandola per adattarla all'immagine di destinazione. Le immagini sono scalate non proporzionalmente; selezionare l'immagine dal disco.

- Colore del Disegno

  • Da progetto: mantiene i colori originali del disegno;
  • Colore personalizzato: scegliere il colore nel menu a comparsa.

- Colore di Riempimento

  • Nessuno;
  • Da Progetto;
  • Monocromatico: scegliere il colore nel menu a comparsa;
  • Scala di grigi;
  • Seppia.

- Tipo di linea: selezionare il tipo di linea dalla lista caricata.

Filigrana

La funzione Filigrana dello strumento “Presentazione del Disegno“ permette di aggiungere una filigrana di testo all'immagine: le opzioni di stile del testo includono Font, dimensione, stile del testo (grassetto, corsivo, sottolineato) e colore. Attraverso un menu è possibile impostare la posizione della filigrana all'interno dell'immagine.

Opzioni di Dimensioni dell'Immagine

In questo pannello sono raggruppate tutte le opzioni per impostare il formato, la dimensione e la risoluzione desiderata dell'immagine risultante.

  • Preset: scegliete la dimensione che meglio si adatta alle vostre esigenze tra i molti formati standard presenti nel menu;
  • Dimensioni in pixel: utilizzare i campi per inserire la dimensione personalizzata dell'immagine in pixel: fare clic sull'icona per fissare il rapporto desiderato;
  • Risoluzione: impostare una risoluzione di 72 dpi per l'editoria web o le presentazioni, mentre le risoluzioni di 300 dpi o superiori sono le migliori per la stampa;
  • Dimensioni di Stampa: è possibile impostare la larghezza e l'altezza della stampa, utilizzando il menu a destra per impostare le unità di misura.

Esportare le Immagini

L'immagine risultante viene visualizzata su una nuova finestra che fornisce alcuni pulsanti, tra cui i pulsanti di zoom: premere il pulsante “Salva” per esportare l'immagine come file TIFF, PNG o JPEG o il pulsante “Copia” per copiare l'immagine negli appunti.

È anche possibile trascinare l'immagine sulla finestra principale del progetto per inserirla nel foglio corrente.

/usr/www/users/ilexsoft/help.ilexsoft.com/data/pages/it/guides/highdesign-r6/strumenti-avanzati.txt · Last modified: 2021/01/30 08:40 by ilexsoft