HighDesign R6 Release Notes

HighDesign R6 Release Notes

GENERAL

Type Change
NEW HighDesign is now a Universal binary app native for both Apple Silicon (M1 chips) and Intel x86 architectures.
NEW Added support for macOS Big Sur.
NEW New Migrate Custom Settings and Resources window.
NEW Redesigned License Activation panel.
IMPROVED Overall speed improvements: file open is about 65% faster; file save 25% faster; redraw 40 to 60% faster depending on the kind of project and hardware; select, deselect and delete commands are more than 100x faster.
IMPROVED Project Browser: added shortcuts to transfer or duplicate the selected objects to the clicked sheet. Hold down the Command (Mac) or Control (Win) key to transfer; Alt to duplicate.
IMPROVED Project Browser: The highlighted bounds of a sheet or a selected object, activated by hovering the Project Browser and the Object Info respectively, are now much more visible.
IMPROVED The Purge command now includes images and external references.
IMPROVED Improved the appearance of popup menus.
IMPROVED Colour chooser buttons now show the colour with the alpha value.
IMPROVED Added a new contextual menu to the Layers panel that provides access to most commands on layers.
IMPROVED Layers listed on the Layers panel (floating or inside the Sidebar) can now be reordered by dragging.
NEW The Layer menu on the Properties bar now includes the commands Show All Layers and Hide Other Layers.
NEW Main drawing tools bar: added button to resize the toolbar to one- or two-column layout.
NEW Updated application and document icons.
IMPROVED DWG/DXF: improved conversion of hatches and added support for multiple-boundary hatch entities.
IMPROVED DWG/DXF: improved the conversion of entity colors.
IMPROVED DWG/DXF: improved import of Leader entities.
IMPROVED Hatch manager: improved navigation, preview and editing.

DRAFTING

Type Change
NEW Image Settings dialog: added a pop-up window to browse inserted and recently used images.
NEW Arcs: added new method Arc by start point, end point and radius.
NEW Added new automatic alignment to horizontal and vertical directions during the construction phase.
IMPROVED Snap to objects: selected objects take the precedence over other objects.
IMPROVED Switching to a different sheet now deselects any items on other sheets.
IMPROVED Objects on locked layers are now ignored by the Selection tool, so that any overlapped, non locked objects can be selected directly.
IMPROVED After the insertion of an image, the active tool switches automatically to Selection to avoid starting the insert process again on click.
IMPROVED The default style/type for the selected tool is now activated as soon as the tool is activated, regardless of the current status of the No Style switch.
IMPROVED Offset tool: restored the ability to connect the offset line with the previous lines.
IMPROVED Fillet and Chamfer commands can now be applied to rectangles and closed polygons, in addition to lines and polylines.
IMPROVED Gradients are now available in HighDesign for Windows.
IMPROVED The Extend tool now calculates the best intersection point with the reference object.
IMPROVED The Apply Hatch at Click method now works with polylines.

DESIGN

Type Change
NEW Compound Walls: it is now possible to set the leading side by the core structural component. Allowed positions are exterior, interior sides and middle of structural component.
NEW Wall options in the Properties bar: added leading side menu.
NEW Doors & Windows: added a pop-up menu on the Properties bar to define the insertion point.
NEW Doors: added new double sliding door family.
NEW Doors & Windows: added new Insert by Structural Width option

PROJECT DOCUMENTATION

Type Change
NEW New Manage Custom Sizes window, used to create and organize custom paper sizes with the ability to get dimensions and margins from the installed printer.
NEW Dimensions now support custom precision settings. Enabled when the dimension units are not by project.
NEW Viewport scale can now be set as “By Drawing” to match the source drawing's scale.
NEW Viewports: added the option to use a detail area on the selected sheet to define the viewport.
NEW The Print preview window on Windows allows the selection of the destination printer.
NEW Detail Areas can now create a viewport directly from their option menu.
NEW Annotations: added support for multiple leader lines. Use the new Add Leader and Remove Leader methods to edit an existing annotation.
IMPROVED Text Settings panel: replaced the sliders of Letter-spacing (Kerning) and Line spacing (Leading) with stepper controls. Improved the synchronisation with the selected object.
IMPROVED Multiple dimensions now support a “Continue” option: clicking an existing dimension allows to continue the sequence using that dimension as base item.
IMPROVED Detail Areas: restored the option to snap to paper sizes and added support for printer margins. The default mode now snaps to the paper size minus the margins. Hold the Ctrl key to snap to the full paper size.
IMPROVED Print: now an alert dialog warns the user when attempting to print on a large number of pages (100+).

Bug Fixes

  1. Duplicating a layout no longer reverts the new layout's paper size to project defaults.
  2. Fixed regression bug that prevented images with alpha channel (PNG, Tiff) to load properly.
  3. Images with resolution lower than 72 DPI now render correctly.
  4. Creating a new drafting sheet when the current sheet is a layout did not update the screen.
  5. Undo/Redo commands applied to the Delete Sheet command did not work correctly.
  6. Extend command now is more accurate at picking the intersection points closer to the click.
  7. Search by pen-weight now works correctly in saved projects.
  8. Lines returned by the Explode command applied to rectangles did not keep their parent rectangle's graphic properties.
  9. Objects returned by the Trim command applied to polylines did not keep their parent polyline's graphic properties.
  10. Dimension tick marks were not visible in viewports.
  11. Edit commands did not properly update the values on Object Info.
  12. Fixed editing of radial dimensions by the end point.
  13. Fixed commands Rotate, Rotate by Angle, Mirror and Mirror a Copy applied to images.
  14. The keyboard shortcuts for Pan and Zoom did not work when the icons where placed on the main toolbar.
  15. Fixed Viewport styles.
  16. Fixed Duplicate and Multiply commands when applied to elements with advanced settings.
  17. Transfer To Sheet and Duplicate to Sheet commands did not properly rebuild the sheet bounds.
  18. DWG/DXF Import: fixed the height of multi-line text boxes; fixed parsing of indented list items.
  19. Changing the visibility or lock status of a layer via pop-up alerts did not update the Layers panel.
  20. Editing the contents of a selected text object inside a group is now possible again.
  21. Images: added safety checks to make sure the image is loaded correctly in saved documents.
  22. The Paste Attributes command did not apply the correct attributes to composite elements like hatches.
  23. The Convert Blocks command did not work correctly with DWG files whose file name contained non-ASCII characters.
  24. PDF: texts could occasionally be clipped and wrapped to an incorrect width.
  25. Ordinate dimensions now honour the label orientation setting.
  26. Transfer to New Sheet did not create the destination sheet.
  27. Object Info could occasionally show the “lock proportions” button when it was not needed.
  28. Tool Settings Window: fixed width of the style popup so that it does not overlap with buttons.
  29. Angular dimensions now honour label orientation settings and support custom label positions.
  30. The command Project > Layers > Mask Other Layers did not work correctly.
  31. [Mac] The Welcome window no longer opens on closing a document regardless of the preference set in the General tab.
  32. Importing a DWG/DXF after exporting now sets the correct measurement units.
  33. The Styles panel now updates correctly after selecting a style from the Styles popup.
  34. When switching from a modified style to any other item in the list, the Styles panel now restores the correct colors.
  35. The Project Browser now highlights the bounds of a sheet only when the Drawing Sheet display mode is not set to Hide Others.
  36. Undo Duplicate, when applied to walls, did not remove all the walls involved in the operation.
  37. Redo New Object did not connect walls and openings correctly.
  38. New doors and windows no longer take the host wall's pen colour and size.
  39. Walls: fixed bug that caused the wall to modify the global default stroke settings.
  40. Walls: multi-wall nodes where two walls were parallel did not build correct joints.
  41. Duplicated groups that contain walls now preserve the correct connections between the walls.
  42. Duplicate works correctly when applied to walls.
  43. Corrected the Duplicate command applied to doors and windows.
  44. Linear Multiply did not work when applied to doors and windows.
  45. Fixed Move and Duplicate commands applied to groups containing walls and openings.
  46. Corrected a visual error that occurred randomly in the selection of windows.
  47. Closed some memory leaks.
  48. Activating the Y/H input field by pushing tab was not handled as “Height”.
  49. Texts in rotated viewports now render correctly.
  50. Viewport Settings Panel: when the viewport's base units are imperial, the scale menu did not open correctly and did not handle the scale notation mode button.
  51. Rotated text label: fixed the auto-sizing of the input box.
  52. Restored the command Fit Text Box to Contents.
  53. Optimized and improved the behavior of popup menus.
  54. Restored the ability to insert images by Paste, image drop and image file drop.
  55. Better handling of errors generated by attempts to open a document without the required privileges.
  56. Improved import of DWG/DXF Multileader entities.
  57. Improved conversion of DWG/DXF layouts.
  58. Fixed an error that would cause the Save command to fail silently when the file and the application support folder were on a NAS volume.
  59. Updating a symbol now correctly updates its instances in the project.
  60. Object Info: the Detail info panel no longer opens with the incorrect height.
  61. Fixed appearance of pop-up windows (styles browser, pop-up panels, etc.).
  62. Graphics: improved the appearance of objects when the high-resolution rendering is active.
  63. Photogrammetry: fixed Select All command; improved rendering of perspective grids and measure lines.
  64. Drawing Presentation: updated the default sizes for Instagram.
  65. Fixed situation that could cause loss of the project data.
  66. DWG/DXF: improved conversion of TABLE entities.
  67. DWG/DXF: improved parsing of styled texts.
  68. Printing isolated sheets did not work correctly.
  69. Door frames are now printed with their correct thickness.
  70. The Publish to PDF dialog now reports the layout numbers.
  71. Project symbols with no associated file in the library can now be edited.
  72. Fixed intersection points of rotated ellipses.
  73. Fixed symbol styles.
  74. Previews of graphic styles did not display correctly.
  75. DWG/DXF: improved export of VIEWPORT entities and paper space objects.
  76. Fixed visualization problem that could prevent vertical construction lines from displaying at certain zoom factors.
  77. Fixed vertical alignment of multi-line labels in annotative tools.
  78. Dimension styles were incorrectly marked as modified after reopening a file.
  79. Editing tools can now be deactivated by clicking their icon in the Editing toolbar.
  80. Windows: fixed user interface of the Print Preview window.
  81. Print Preview: changing the printer or the page setup now correctly updates the calculated scale factor when the “Fit to on page” option is active.
  82. Windows: addressed minor printing inconsistencies.
  83. Windows: fixed viewports in PDF.
  84. Windows: fixed rotated labels in PDF.
  85. Publish to PDF: when the page size is set as “By Sheet”, the size of the pdf page is calculated on the paper size of the sheet if available, rather than calculating it on the contents.
  86. Improved bound calculations of linear dimensions to include the entire label box.
  87. Viewports: fixed the scale of represented hatches.
  88. Windows PDF: fixed the size of text labels in viewports.
  89. Fixed behaviour of Edit commands like Cut, Copy, Paste, etc. when an input field is currently active.
  90. The Duplicate to Sheet command did not update group members correctly.
  91. Fixed Duplicate Sheet when the sheet includes groups with walls and openings.
  92. Hatches from exploded mirrored symbols were not placed at the correct coordinates.
  93. Fixed Detail Area / Callout styles
  94. Misc. fixes in Drawing Presentation window and image creation.
  95. Photogrammetry: the Extend and Join commands now update the projection.
  96. Photogrammetry: Select All objects by class now works properly.
  97. The Resize Drawing by Measure did not apply to all the objects on the sheet.
  98. Images of the current drawing created for export or drawing presentation now use the highest quality antialiasing.
  99. Viewports: fixed clipping of objects when the view is rotated.
  100. Fixed Explode command applied to mirrored symbols that include arcs and curves.
  101. Doors & Windows: it is now possible to insert an opening exactly on the start or end point of a wall.
  102. Drawing Presentation now checks the size of the image before starting the rendering.
  103. Opening a tool settings window in a document no longer activates another open document with the same panel active.
  104. Improved snapping to wall end points.
  105. Fixed the joints of walls when the “Allow start joint” option is disabled.
  106. Zooming with the mouse wheel now always includes 100% in either direction.
  107. Printing a detail area no longer leaves traces of objects in the paper margins area.
  108. DXF/DWG: groups with multiple levels of sub-groups are now exported correctly.
  109. The Polygonal Selection method of the Selection tool did not show the selected items after the double click.

HighDesign R6.0.1

(2021.0.1.1855)

Bug Fixes

  1. The clipping of some objects in underlays was not accurate.
  2. Items that have been ungrouped could not be deleted.
  3. Dashed construction lines no longer scale with the current zoom.
  4. Corrected situation that could freeze the app when moving large groups with sub-groups.
  5. Layer names are now always regarded as case-sensitive.
  6. Printing a drawing when the sheet display mode is set to “Hide Others” (isolate) now works correctly.
  7. Removing a layer and changing the layer of the objects now works on all types of sheet.
  8. DXF/DWG out: improved formatting of exported multi-line texts.
  9. DXF/DWG out: the coordinates of single leader lines were incorrect under certain circumstances.
  10. DXF/DWG out: fixed the view settings when the exported drawing contains one horizontal or vertical line.
  11. DXF/DWG out: single-vertex polylines are no longer exported.
  12. Improved the appearance of the focus highlight area that is drawn when the pointer is over the Object Info or Project Browser panes.
  13. Layers pane and Layers manager panel: attempting to rename or add a layer with the same, case-sensitive name as another layer now shows an alert.
  14. Changing the UI theme in the Preferences window now works correctly.
  15. Objects near the window border no longer disappear from view when zooming in.
  16. The view of new drafting sheets now shows the origin of the axes in the lower-left corner.
  17. Clicking outside the text field on Project Browser, Layers pane and other panes now accept the changes instead of reverting to the previous text.
  18. Improved the appearance of disabled buttons in dark theme.
  19. Made sure that entered or modified resource names are treated in the correct text encoding.
  20. The File > Close command now closes the Welcome window when it is in front of other windows.
  21. Fixed clipping of dimension labels when printed in a detail area.
  22. Replaced the sounds for “Done” and “Project View” actions.
  23. Updated the background color of popup menus on macOS.
  24. Fixed output of negative values expressed in fractional inches.
  25. The Units pane in Project Settings did not show the correct fractional precision.
  26. Fixed several glitches in the Project Views pane.
  27. DXF/DWG: improved the export of multi-line texts and fixed the text encoding of the exported text values.
  28. Windows: fixed a number visual issues in the Resource Manager.
/usr/www/users/ilexsoft/help.ilexsoft.com/data/pages/en/articles/highdesign-r6-release-notes.txt · Last modified: 2021/03/25 10:26 by ilexsoft