User Tools


3 Get started

  • Start a New Project
  • Project Settings
  • Organize the Project
  • Save & Open
  • Import & Export Drawings
  • Print and Output
  • Project Utilities

Start a New Project

When you launch HighDesign, the main window opens blank and ready to start a new project. The default new document is generated with units and colors set according to the current preferences of language and theme.

If you have closed all documents and want to make a new one, select File ▸ New and a new window will open.

When you start a new project in HighDesign, you typically want to set up the initial properties such as page format, drawing units, colors. HighDesign separates the Application preferences from the Project settings.

In Preferences, you set the global options that belong to the application itself, such as auto- save or undo level, and the settings regarding your own drawing style and preferences.

The Project Settings provide options that are relative to the current project only.

Project Settings

Before starting a new project, it is useful to set up the main settings and drawing utilities according to the drawing standard you wish to use in the current project, such as the paper format and size and the sheet drawing units.

In HighDesign the Project Settings window, available through the File menu and through the Project menu, includes the panes to set all the default drawing options specific to the current project.

Paper Format

The Paper Format pane lets you select the default paper size of the entire project from a list of standard sizes (ISO, ANSI/ASME and US ARCH) and activate the options for Page orientation and margins.

Once you select the Standard, by clicking on the desired sheet size in the thumbnail, and you choose the “Margins” option (Current Printer or Custom Margins), a visual aid will be displayed on screen showing the page extents of the selected size and the corresponding print margins as a cyan frame: you will use this aid to check if your drawing is entirely within the margins.

The Global Settings section lets you set the page margins that will be visible in all pages of the project if the Margins option is active.

Differently from above, the Paper Size window of the Drafting Sheets of the Project Browser and the Paper Size section of the Object Info of Layouts define the paper options of the current sheet or layout only: these options can be by project, custom or by standard.

Sheet Units

Use this pane to set your preferences for linear and angular measurement units. Available options are:

- Linear units, available as Millimeters, Centimeters, Meters, Kilometers, Decimal Inches, Feet and Decimal Inches, Decimal Feet, Fractional Inches, Feet and Fractional Inches, Decimal Yards, Miles, Points and Pixels; - The number of decimal digits to be displayed; - Angular units, selectable from Decimal Degrees, Degrees and Minutes, Degrees, Minutes and Seconds; - The number of decimal digits to be displayed when in decimal degrees; - The option to use normal angles, bearings or azimuth; - The direction of the North used by bearings and azimuth directions; - Area units used to express area calculations and values; - The decimal separator to use; - Suppression of zero digits (not available in HighDesign LT).

Grid

You can use this pane to customize the grid and set grid options:

- Horizontal and vertical size; - Number of subdivisions; - Grid color: automatic (changes with the current background color) or custom; - Option to display the grid behind or in front of the drawing; - Option to print the grid; - Option to set the snap to grid as exclusive; - A button to show / hide the grid;

Appearance

This pane lets you customize your HighDesign work environment. You can:

- Choose a background color; - Select the color of selection handles; - Choose to highlight selected objects;Choose the color of construction lines: by object (through the Properties bar) or custom; - Set the line-type of construction lines as continuous or dashed.

Project Information (Pro)

Use this pane to add non graphic information to a project, such as author, project name, description, client name, project location, status or to set an issue date of the project; Project Time shows you the time you have spent on the project.

Most of these information correspond to the attributes of the Title Blocks and will be automatically added to the title blocks used in the Layouts of the project.

Organize the Project

A project is a complex set of drawings, symbols, views, details and documentation elements such as annotations, tags, dimensions and non graphic information. All these elements need to be organized and arranged in a convenient way.

Layers, Drafting Sheets and Details allow to manage the project effectively.

Layers

A layer is a concept used in CAD and design programs to conveniently group elements in a logical way. As its name implies, this concept derives from the use of overlaid semitransparent papers in manual drafting. As in manual drafting, layers are used in HighDesign to organize a complex drawing into different component parts, but, differently from real layers, each CAD layer has its own properties.

Decomposing a drawing into its components is one of the most important operations in computer design. Any object, even the most complex, can only be analyzed by separating its elements in logical groups, applying criteria that depend on the object nature and on the designer goal.

Any element of a drawing in HighDesign belongs to a layer: there is no restriction on what types of objects you can assign to a layer. You are free to group different elements together in the most convenient way to you or according to the drawing standard you are following.

HighDesign layers have the following properties:

- Name- layers are identified by their name;

- Visibility- a layer can be visible or invisible. Items belonging to a visible layer are redrawn to screen, are printable and selectable; invisible layers are not printed.

- Lock- layers can be locked to make their items not selectable.

- Color- layers can have a default 32 bit color. If the byLayer option is on (you can change it by opening the “Colors” pop-up menu in the Properties bar and selecting “byLayer”), any new item gets the color of its layer.

- Drawing tool binding- you can create a binding between a drawing tool and a layer so that, every time you activate that tool, the layer is set automatically.

Quick Layer Management

The layers of the project are listed on the Layers menu of the Properties Bar: select the desired layer by a click to update the current default or to change the layer of the selection.

The name of the current layer or of the layer of the selection is shown on the button of the menu.

The Layers menu displays the main functions to manage layers: you can switch to other layers, show or hide layers, lock some layers and access the Layers Manager to create and arrange new layers.

The commands on the upper section of the menu allow to create new layers, open the Layers pane of the Resource Manager window and switch layer masking on and off.

You can mask the layers of a project so that only the current layer is visible and editable. Masking is a switch on/off command, and as long as the mask is active, changing the current layer will automatically hide the other layers. Once masking is switched off, the other layers return to the original visibility they had before the command.

Layers are document based and are only available to the project you created them for.

Drafting Sheets

As it is in manual drafting, a project is made of different sheets, each with its own page size, drawing scale and units, depending on the part of the project it represents. HighDesign provides an intuitive way of handling projects by introducing the concept of “Drafting Sheets.”

A Drafting Sheet in HighDesign has special attributes such as visibility, write-protection, etc., that make it a convenient way of organizing a project: you can, for instance, put a different drawing on each sheet or use a sheet for the main drawing and draw sections on additional sheets.

A HighDesign project, either for architecture, engineering or design, is thus made up of several drawings contained in a single document.

The ability to show or hide sheets, transparency and write protection allows you to compose a complex project even in a single layout.

The following are some of the properties and advantages sheets provide:

- Independent drawing scale and optional paper size of the current sheet; - Independent drawing units; - Write protection and display mode (visible, hidden and dimmed); - You can search and select items on a single sheet or on all sheets; - Visible sheets can be merged into one; - You can create and delete any number of sheets; - The print functions only prints the visible sheets; - A sheet can be saved as a new document; - Sheets can be reordered and renamed; two or more sheets can share the same name;

Drafting Sheets are managed through the Project Browser Panel of the Sidebar and via the Project menu, which provide all the commands to create, rename, delete and reorder sheets, move and duplicate items across sheets, show and hide, etc.

Project Browser (not available in LT edition)

The Project Browser shows a logical hierarchy for all the Drafting Sheets of the project and also lists Details and Layouts which are special sheets used to present the project. By using this panel you can quickly create, rename and delete sheets, change their visibility, protection, optional size and scale attributes.

To create a new sheet, click the New Sheet button (+) and modify its name. By default, new sheets are created with the current drawing scale and units. You can change the units and scale of a sheet by double-clicking it on this window.

To arrange a sheet, drag it to the new position: the table order corresponds to the actual display order, where the topmost visible sheet is the first item of the list.

You can control how the sheets are displayed on screen by clicking the Opacity button. There are three states: all sheets equally visible, the current sheet displayed normally and the others dimmed, or only the current sheet visible.

Drafting Sheet Properties

From left to right, the properties of a drafting sheet accessible through the Project Browser are:

- Visibility, on or off; - Optional Paper Size: double-click the page icon or use the Object Info panel to change the paper size of the current sheet; - Name: double-click to rename the selected sheet; - Sheet Protection: click to switch; protected sheets are visible but are invisible to the snap; - Drawing scale and units: click to open the units and scale menu.

Utility Buttons

The Project Browser panel provides several buttons on the footer of the window to quickly access functions and set options.

- New sheet: adds a new sheet at the top of the list; new sheets have a default progressive name which can be changed by double-click. - Delete selected sheet: all objects of the current sheet can be moved to another one or deleted. - Action menu. The action menu lists the commands to manage sheets as in the Project menu, apart from those specific to the selected objects of the drawing, and the commands to change the visibility status of all sheets in relation to the current one. - Display modes: All Visible, Dim Others, or Hide Others.

Details (Pro)

Detail Sheets are specialized drafting sheets used to add detailed views of the project. Details can be created as independent drawings or as drafts linked with selected Detail Areas of the project as well. You can create new Details through the “Add” button in the Project Browser panel or via the New Independent Detail command on the Project menu.

Once you create a new detail you are asked to enter name, scale and units. When drawing a detail you can use sketching and documentation tools but design tools as Walls or Windows are not available.

Details linked with a Detail Area show the source drawing enclosed by the area as an underlay with adjustable opacity, available as a reference for drafting. Also, the underlay can be exploded and turned into a group for editing and further transformations: to explode the underlay you can use the “Explode Underlay” button on the bottom-right corner or the drawing area or the proper command in the Project menu.

The Object Info panel provides the main information and options of the current Detail. Details do not have the Paper Size option.

Save and Open a Document

All the functions needed to correctly manage your documents are available in the “File” menu, and many of them are easy to understand as they are standard commands in all applications.

New Document From Template

Through this function you can use an existing template for the new project: this preset includes properties like units, sheet size, layers, line-types, hatches, title blocks and graphic objects. Default templates are available with the imperial and metric drawing standards of architecture and engineering.

Open a Document

To open a HighDesign project stored in a known location, select File ▸ Open…; if you want to quickly open a recently modified document, choose File Open Recent “project- name”.

The “Open…” command also lets you convert and open “.dsn” files from previous versions of HighDesign.

Merge Two Projects

Select File Merge… to open a project inside the current one: the merged project will contain layers, sheets and symbols from both source projects.

Insert an Image

HighDesign lets you easily add pictures to your project from several graphic formats (TIFF, JPEG, PNG, GIF, PDF). Images inserted into the project keep their resolution and are displayed at the real print size: it is also possible to handle them as any other vector entity. PNG and TIFF images are imported with their alpha channel if present.

To insert a picture in your project, select File Insert Image…, choose the image and place it at the desired position with a click. Alternatively, you can drag an image from another application, such as a web browser, drag a file directly onto the drawing canvas, or use the Paste command to paste an image from the clipboard.

PDF documents can be inserted as high-resolution images. When you choose a PDF document with the Insert Image command, you are presented with a dialog where in you can select the page to import, if more than one, and set the resolution at which the image object will be created.

If you use the Pro version of HighDesign, you can also enhance the image by adjusting brightness, contrast, saturation, size, sharpness, smoothing factor, etc. To set size on screen, print size, resolution and transparency of images, use the Image Settings window on the Edit menu.

Save a Project

The “File” menu includes all the basic functions to save the current document to the desired storage location:

- Save lets you save on disk the current project; if the project does not have a name, a standard save dialog is shown on the screen. - Save As… saves a copy of the current document with a new name; - Save Special has a sub-menu:

- Selection As New Document saves the currently selected items into a new file; - Sheet As New Document (Pro version only), saves a copy of the current sheet into a new file; - Visible Sheets (Pro), saves only the sheets that are currently visible; - New Symbol lets you save the currently selected items as a new library symbol; - Symbol View lets you save the selected items as a new view of an existing symbol; - Template (Pro version only) stores the current properties and graphic objects as a reusable template.

HighDesign Projects have the “.dsn” file name extension.

Import Drawings

It is possible to import projects saved by other CAD programs by using the DWG/DXF file format, which HighDesign supports from version R9 to 2018-2020.

Import DWG/DXF Drawings (DWG not available in LT edition)

Select File Import Single DXF/DWG file. Before opening a DXF/DWG file a dialog lets you set the basic import settings:

- Drawing units to be used to convert DXF/DWG elements; most DXF/DWG versions do not include a measurement unit; - Destination scale of the drawing; - When the “Use file drawings units” option is active, HighDesign tries to set the drawing units as found in the file. If no drawing unit is found this option has no effect; - Options to set the background color to black or to add a prefix to layers;

HighDesign Pro imports DWG/DXF documents with both Layouts and Model data: when opening the document, the drawing, or Model, is located on the sheet named “Model” and the Layout objects are located on the Layout sheets.

Import DWG/DXF Blocks (Pro)

Use the “Import DWG/DXF Blocks” tool to convert a folder of DXF/DWG blocks or drawings to HighDesign-native symbols. Converting a symbol library is a two-step process, all performed in a single window.

Choose File Import Import DWG/DXF Blocks…; the following window opens:

1. Conversion options - convert blocks/drawings within one folder or blocks within one DWG/DXF file. Push the Choose button 2. When the import process is complete, you can use the table to review and edit the imported symbols. 3. Preview of the symbol. 4. Click the Convert button to save the HighDesign symbols into your current Library folder.

The list of symbols can be reordered by dragging the rows.

The first step consists of selecting the folder on your disk and importing all the readable drawings contained in it. Supported formats are all DXF versions from R10 to 2013 and all DWG versions from R9 to 2015 (DWG support only available in HighDesign Standard and Pro).

Push the Import button to choose the folder. If the selected folder contains readable files, the standard DXF/DWG Import dialog opens allowing you to set the scale and drawing unit options.

With the second step you can set the options and complete the conversion to HighDesign symbols. The table displays name, scale, width, height and the preview of each symbol, letting you modify the attributes of the symbol before it is saved.

Export Your Project

Your project can be exported to many graphic formats. Select File Export As and choose the destination file format:

- DWG file format from version R12 to 2018-2020 (.dwg). - DXF file format from version R12 to 2018-2020 (.dxf). - DXB (.dxb) versions R12-2018-2020. - Vector PDF (.pdf) - (Pro only). - TIFF (.tif). - JPEG (.jpg). When you export a drawing to JPEG, a dialog lets you set the compression quality and JPEG specific attributes. On the right half of this dialog, a preview shows the new file and the original image. - PNG (.png). PNG supports high DPI and provides the option to export with the Alpha channel. Alpha channels are 8-bit masks that make the final image transparent. In HighDesign, a PNG with alpha channel is a transparent image with no background. - GIF (.gif).

The Export as DWG/DXF dialog shows some options:

- Format version via a pop-up menu. Also available in HighDesign Standard; - List of sheets of the HighDesign project and ability to select Drafting Sheets, Details and Layouts to export; - Option to export all selected sheets as a single DWG/DXF document; - Option to export each selected sheet as a separate document (all documents are collected in one folder).

Extend the default Symbol Library

Even though HighDesign comes with a default collection of symbols, it is possible to extend it by creating new custom symbols or by adding external libraries: the “Add Symbol Library” command on the File menu lets you select a folder of HighDesign symbols to be stored in the desired location within the Custom Library folder.

Print

The print function produces high quality prints on any page format supported by your printer.

The basic concept behind printing in HighDesign is “what you see is what you get”, meaning that not only the printed page will look as much as possible as the drawing on screen, but also that no scaling, hiding or other operations are required in order to print the drawing. If the project includes sheets at different scales, they will be printed with the same relative proportions.

All print operations are performed by selecting one of the print items in the “File” menu.

- Page Setup: opens the standard page setup dialog of your Operating System. Use this dialog to select the printer and set page size and orientation. - Print: opens a dialog to set HighDesign specific print settings and get information about actual drawing extents and number of pages that will be printed.

Some items of the project are not printable: Detail Area frames and Selection handles.

Construction objects such as datum points, grid, and construction lines can be printed if the “Print Construction Objects” checkbox in the Print dialog is active.

This window contains the Project View pop-up menu, to choose the view you want to be printed with its corresponding set of visible sheets and layers (Pro-only feature), the Layout pop-up menu, used to set the position of the printed drawing relative to the pages, and the Printable Area pop-up menu, providing a list of possible print options. Available options are:

- Whole drawing: prints all items on visible sheets and layers; - Selected items: only prints currently selected items; - Detail Areas: from a list of available Detail Areas, this options only prints the region of drawing included within the bounds of the selected area.

The Print button opens your printer’s Print Settings dialog. This dialog may include different panes for each printer manufacturer.

- Print. Use this menu to select the current view, a saved project View to automatically show and hide sheets and layers accordingly, or a Layout. - Area. Options of this menu are: Whole Drawing, to print all the visible objects in the drawing; Selected Items, to print only the objects currently selected; any available detail areas created with the Detail Area tool. - Actual extents of the drawing being printed and number of pages required to print the drawing (rows x columns). - Alignment menu, showing the options to lay out the drawing within the page. - Preview of the printed page. - Resolution menu. Set the print resolution from 180 to 1200 dpi (600 dpi is the default). - Scale field to set custom reduction/enlargement factors.

- Option to scale the printed drawing to fit the current page.

- Filter menu. Lists the options to print by project color settings and to print all colors as monochromatic through the colors menu. Sub-options are the ability to exclude fill colors and to disable the color interpolation of stroke lines. This last option allows to print the drawing with a fixed color regardless of the brightness of the original color in the drawing. - Options:

- Print pen-weights option: uncheck to print everything as thin lines. - When “Fit to one page” is set, the Scale pen weights option allows you to choose whether the pen weights should be scaled to match the new zoom factor of the printout. - Print margins: if checked, small marks are printed at the corners of the available printable area on each page. - Print construction objects: if selected, construction points and lines of the selected view will be printed.

Project Utilities

Repair Document

Documents can contain damaged or invalid objects when they are imported from other formats, or when crashes or power failures occur while saving a project.

This command checks the document for damaged items, such as unreferenced hatches, incomplete vertices or zero-length segments, and deletes them. It also rebuilds the internal identification handles of each object and checks the bounds of the windows.

To repair the document, choose Help Repair Document. This command cannot be undone.

Purge Unused

A project, especially when opened from a different edition of HighDesign or when imported from a different file format, can include unnecessary resources and items, like unused line-types, hatches, symbols.

To remove unused items from the project, choose Help Purge.

In the dialog window, check the kind of items and resources that you want to purge and click OK. Default resources that are loaded automatically with each new project will not be deleted, even if unused in the current project.

This command cannot be undone.