User Tools


4 Essential Skills

  • Snaps and Alignments
  • Constraints and Coordinates
  • Object Info
  • Zoom and Pan
  • Set Graphic Properties
  • Styles and Types

Snaps and Alignments

HighDesign provides automatic grid, object, vertex, intersection, right-angle / tangent and alignments snap. Snap is a function that allows you to draw with the maximum precision by automatically setting the insertion on datum points of objects or by joining endpoints of lines and other objects Snaps can be toggled on and off through the Snaps menu on the bottom-left hand side of the main window in the Input Bar. Snap options can also be displayed as a handy floating window available via the Window menu.

Snap Types

The Snap function is always highlighted by a different shape of the pointer, corresponding to the current snap condition: if the “Play Sounds” option of the Workspace pane of HighDesign Preferences is active, the snap function is also pointed out by a typical sound.

The available snap options correspond to the following snap types:

- Snap to grid: the pointer snaps to grid intersections and sub-divisions; - Snap to endpoint or vertex; - Snap to object: the pointer recognizes a minimum distance from an object body; - Snap to intersection: all intersections are interpreted as endpoints; - Snap to right-angle: the pointer changes when the current segment intersects another one with a right angle; - Snap to tangent: the pointer changes when the current line is tangent to a circle / arc; - Snap to alignments: the pointer snaps to two temporary guides; - Snap to Sub-Objects: allows to snap to the objects inside the instances of symbols inserted into the project and inside the Viewports inserted in Layouts.

Alignments

When the pointer snaps to one endpoint of an object, that location is stored as current origin of the temporary guides; the guides are displayed when the cursor is on the X-axis or Y-axis of that datum point.

The pointer also snaps to the intersection of the guides: the intersection is highlighted with one point and both the guides visible.

Furthermore, when you place the pointer over one segment, this function stores the angle of that segment displaying the corresponding parallel and orthogonal guides: when tracing the line, just place the pointer over one datum point of that segment (endpoints or midpoint) to display the alignment.

To temporarily disable the Snap to alignments, hold the “cmd” key.

Constraints and Coordinates

The Drawing Constraint functions allow you to quickly draw items with some conditions, such as parallelism, angle constraints or intersections. The Input Fields on the Input Bar allow you to enter the coordinates of drawing points and the geometric dimensions of the objects, like length and angle.

Constrained Directions

Linear or polygonal graphic objects such as lines and Poly-lines, rotated rectangles, hatches, arcs and ellipses by radius and diameter, dimensions and walls, can be drawn aligned with one of the Cartesian Axes or rotated by steps of 15 degrees: to do this, just press the Shift key while moving the pointer.

Constrained Parallel, Right-Angle and Aligned/ Tangent

These three buttons on the Input Bar provide the Right-Angle and Parallel constraints and the Intersected condition.

Constrain Parallel (P) and Right-Angle (R)

These conditions can be activated anytime with any tool or editing function and will affect the direction of the current movement.

To activate the Right-Angle or Parallel condition:

- After the first click of the current operation you are performing, click the button corresponding to the desired condition or press its keyboard equivalent (P or R); - Click the reference object, e.g. the line you want to draw perpendicular or parallel to (the mouse-cursor changes to a pointing hand when on a valid object); - To cancel a condition, press the Esc key on the keyboard.

Constrain Aligned/Tangent

This condition constrains the pointer to intersect a reference line or circle, extending the line you are drawing to the intersection point, even outside the segment bounds, or constraining the direction to the tangent.

To activate this condition, click the button in the Input Bar or press its keyboard equivalent. If the condition is activated before the start point is defined, it constrains the start point to be aligned to the line or tangent to the circle. If activated after the first click, it constrains the end point.

The same result can be achieved by pressing the Command key + click on the datum line while drawing the line, polygon, wall or hatch/fill.

The Constrain Tangent option can be activated to construct a line tangent to an arc or circle, either from the starting point or to the end point.

To construct a line tangent to an arc or circle from the start point:

1. Activate the Constrain Tangent option. 2. Click on the reference arc or circle. As you move the pointer, the start point of the segment will keep the tangent condition that is closest to the clicked point.

To construct a line tangent to an arc or circle on the end point:

1. Click to define the start point of the line. 2. Activate the Constrain Tangent option. 3. Click on the reference arc or circle.

The drawing constraints and the snap options can also be displayed as grouped in a floating window you can move to a convenient position on the screen. To show this option, select “Snaps” on the Window menu.

Coordinates, Distances and Angles

The Input fields are grouped together in the middle of the Input Bar: use these fields to enter the values of constrained coordinates, length and angle of the object you are drawing. The X, Y and L fields also support additions of partial values.

When you click on one field or use the keyboard shortcut, a visual aid shows up to point the current constraint out.

In all input fields, values can be entered either as numbers, such as “100”, or as a sum of numbers, such as “100+20+60”.

X and Y Coordinates

Coordinates in HighDesign are either absolute or relative. Absolute coordinates are calculated from the global origin point of the drawing, and relative coordinates are calculated from the previous point of the object.

The insertion point of an object, that is its start point, is always set and viewed in absolute coordinates, with the X and Y values calculated from the origin of the current sheet. The next point is relative by default, but you can change it from relative to absolute by clicking the X or Y icon on the input field.

For example, in a line with points at (20, 20) and (100, 100), the end point is (100, 100) in absolute coordinates and (80, 80) in relative coordinates.

To set the absolute insertion point:

1. Click on the corresponding input field or press the “X” or “Y” keys on the keyboard; 2. Enter the desired X or Y distance from the Origin; 3. Press Return to confirm.

To set the relative end point:

1. Click on the coordinates fields or press the “X” or “Y” keys on the keyboard; 2. Enter the desired dx or dy distance from the start point; 3. Press Return to confirm.

You can change from relative to absolute coordinates and vice-versa by clicking the X or Y icon on the input field or using the corresponding key shortcuts.

Constrained Length

You can constrain a segment, line or radius to a fixed length after you have set the start point. In HighDesign, there are two methods for constraining a length that can be used interchangeably.

A. Define direction, set length.

1. After the insertion point is set, move the pointer at the desired angle of the next point; 2. Enter the desired length, either as a total length or as a sum of partial values; 3. Press Return to confirm;

B. Define length, set direction.

1. Click on the Length field or push the “L” key on the keyboard; 2. Enter the desired length; 3. Press Return to confirm; 4. Move the pointer to set the angle of the vector.

Constrained Angle

To constrain the pointer movement to a fixed angle:

1. Click on the “A” field (Angle) or push the “A” key on the keyboard; 2. Enter the desired angle value (in degrees); 3. Press Return to confirm; 4. Move the pointer to set the desired length.

Relative Angle

It is possible to constrain the pointer to a relative angle to a reference direction:

1. Click on the “A” field or push the “A” key on the keyboard; 2. Enter the desired angle value (do not push the “Enter” key); 3. Click on the reference direction (line, poly-line segment or wall); 4. Move the pointer to set the destination length.

Constrained Distance

To set the distance of the insertion/start point of an object from a datum point, type the value, push Enter and click on the datum point; the distance is now displayed as a radius from the datum point: click to set the insertion/start point of the object.

Activate drawing constraints by using the TAB key

Drawing constraints for X and Y coordinates, Length and Angle can also be activated by pressing the Tab key on the keyboard. When you first push that key it activates the X constraint; then, in order, Y, L, A. Activating the Y constraint stores any values inserted into the X field, so to make it easier to set the coordinates of a point.

Object Info

The Object Info panel provides easy access to coordinates and other geometric parameters and to textual information of the selected objects. If no graphic objects are selected the Object Info panel provides all the information about the current sheet.

You can use this panel to read and edit the coordinates of any of the control points of the object, width, height, length, angle, etc., according to the type of object, and its information if available.

Also, the Object Info panel is the main interface to setup the current sheet, detail or layout: the different sections of the panel provide all the controls and fields needed to set name, scale, units, page size, graphic options and other information.

Explore the Object Info panel

By default, Object Info modifies all the selected objects of the same type. To modify only the current object, whose values are displayed on the panel, open the pop-up menu on the header of the panel and choose “Apply Only to Current Object”. This option stays selected until changed again.

The panel is organized into distinct sections whose number depends on the type of the selection.

Sections for graphic objects are:

- Point, available to all graphic objects; - Geometry, for all graphic objects; - ID for objects having their Settings window.

Current Sheets have the following sections:

- Sheet, available to drafting sheets, details and layouts; - Paper size, available to drafting sheets and layouts; - Settings, for details and layouts; - Info, for layouts only.

When you select one or more objects in the drawing, Object Info immediately displays all the numerical properties of the last selected object. The icon and name of the current object are displayed on the top bar of the window, along with the back and forward arrows used to browse through the objects in the selection.

Some objects like symbols, texts, dimensions or walls have special settings that are not displayed on the Object Info panel: when one of these objects is selected it is possible to open its Settings window by clicking the icon on the top bar of Object Info or via the Show Settings button in the ID section.

Point

The Point section displays the X, Y coordinates of the current point. The current point is highlighted in the drawing, and you can use the back and forward buttons to scroll through the handle points of the object. To change a value, click the field, insert the new value and press the Return key on the keyboard.

Depending on the type of object and the active point, the resulting action of editing the coordinates of the active point can either be a stretch or a move. For instance, if you edit Point 2 of a line, it is stretched; if you edit Point 3 of a circle (its center), the action is a move.

When a rectangle or a polygon is selected, this section shows the kind of transformation compatible with the current active point. With poly-lines it is possible to modify the convexity of the segment described by the active point.

Geometry

The Geometry section displays values describing the size and orientation of the object, like width, height, radius, length, angle, etc.. Fields like Width and Height can be connected to constrain the proportions of the object.

This section also displays read-only values that are computed by the current coordinates and size, like perimeter and area.

Some objects, like dimensions and measure paths, only display their value in a read- only field, since they are actually dependent on other objects for their size. Walls add some controls for quick construction changes.

ID

This section is specific to those objects having the Settings window and shows textual information. Here it is possible to set name, tag or add custom information to the selection.

This section also provides the button to open the Settings window of the object.

Zoom and Pan

These viewing tools, by default grouped in a handy dock on the border of the drawing area, are essential to handle drawings. The first time you launch HighDesign Panning, Zoom and Zoom to fit are docked as semi-transparent buttons on the top right corner of the drawing area: by right-clicking on the dock you can open a menu with the options to change the position of the dock.

Also, in the Zoom and Scrolling section of the Workspace pane of HighDesign Preferences you can open the “View controls” menu to change the position of the dock or to display the controls in the main toolbar.

Pan

Use this tool to drag the drawing area and quickly move the current view. To use the Panning Tool click and drag the mouse pointer. Double-click the tool icon to set the view to the center of the drawing.

The panning tool can also be temporarily activated with any tool by pressing the space bar on the keyboard: if you already started a task, for instance drawing a line, the use of the panning tool will not interfere with the current function.

With a multi-button mouse it is possible to pan the drawing by clicking the middle / wheel button and dragging the pointer.

Zoom

The Zoom tool allows you to enlarge or reduce the current view of the drawing by zooming in or out.

Click on the start point, then move the pointer and click again the define the rectangular area that will be zoomed. Hold down the Option key to zoom out.

The zoom factor is inversely proportional to the size of the zoom rectangle, that is, the smaller the rectangle is, the higher will be the factor.

Double-click the tool icon to set the view factor back to 100% (actual view).

Other zoom commands are grouped under the View menu, including “Zoom to Fit”, “Zoom In” and “Zoom Out”.

Dynamic zoom is enabled by pressing “cmd and +” or “cmd and -” buttons on the keyboard or, with a multi-button mouse, by rotating the wheel: rotate the wheel forward to zoom in and backward to zoom out. Trackpad gestures are also supported by the dynamic zoom.

Zoom to Fit

This viewing utility control is also available as a button in the dock of the viewing tools: by clicking this button the zoom factor and the center of the view are adjusted to fit the extents of the drawing area. This way you get a panoramic view of the whole visible drawing.

When one or more objects are selected this control centers the view of the selection only.

Set Graphic Properties

Most of the attributes common to all object types can be set and changed in the Properties Bar. Properties that are shared among most object types are: layer, pen color, fill color, pen line types, start and end markers, pen weight.

To set the properties for new items, make sure no object is selected and then use the controls on the Properties bar. To edit the properties of an object, select it and then change the corresponding values.

Graphic properties specific of some objects, such as extension lines of dimensions or hatches and fill color of walls, are managed through their Settings window.

Layers

Use the Layers pop-up menu in the Properties bar of the main window to set the current layer and change layer to selected items. On the left of the layer name there are the icons of the color, visibility and lock attributes: click them to edit those attributes.

To change the layer of an item, select it and choose the new layer from the Layers pop-up menu. Through this menu it is also possible to create a new layer, open the Layers Manager pane of the Resource Manager window and mask other layers to keep visible only the currently selected layer.

Pen Color

Use the Pen Color pop-up menu to select the current pen color or change the color of selected items. Pen color controls the color of the outline of objects.

You can choose a pen color from a palette of 256 indexed colors; use the color of the current layer with the By Layer option; set a contrast color; or set no color at all. When the “By-Layer” option is activated, the current color is that of the current layer. With the “Color by Contrast” option the color is automatically set on screen as white with dark backgrounds or black with light backgrounds (invariably black on printouts).

Fill Color

The Fill Color pop-up menu controls the options for filling a shape with color. The button is active only for objects with the fill property, like poly-lines, polygons, fills, arcs, circles and ellipses and walls.

Available options are:

- The palette of 256 indexed colors with adjustable opacity, varying from 0%, fully transparent, to 100%, fully opaque. - No color button. - System color picker. - Gradient. Use this button to switch from solid color to gradient.

Gradient Editor (Mac only)

The gradient button on the Fill menu opens the Gradient Editor. A gradient is a fill that varies its color from a start color to an end color, with variable opacity. Available gradient types are linear (or axial) and radial, and can be activated through the buttons on the top left hand corner of the window.

Next to the type buttons is the Invert Colors button, which inverts the colors in the gradient slider.

The Angle slider and field control the angle between the start and end points of the gradient.

The Color slider controls the colors and their locations along the axis. Click a color to open the color menu and adjust its opacity; click on the slider to add a color; drag a color along the slider to change its location; drag the color vertically to remove it.

By default, changes are visible in real time. Depending on the complexity of the project, you can click the Show Preview checkbox to disable the live preview.

The geometry of a gradient, that is position of the end points and radius of the circles, can be edited by selecting an object with a gradient and adjusting the points on screen.

Linear Gradient

A linear gradient is an interpolation of color that varies along a line between two defined points. When you select an object with a linear gradient, a line with two endpoints marks the linear gradient. You can edit each point and adjust the gradient as needed.

Radial Gradient

A radial gradient is a fill that varies along an axis between two circles. In a selected object, a radial gradient is displayed with two circles, typically of different sizes. The second circle, corresponding to the end color, must always be contained inside the first circle. Start points are marked with a square handle, and end points with a round handle.

NOTE Due to the underlying graphics engine, gradient colors with varying opacity cannot be printed or saved as PDF. On print or PDF, such gradients are captured with an opacity value of 100%. Transparent gradients can be exported to an image format such as TIFF, PNG or JPEG.

Line Types

Use the Line-type pop-up menu to set the current line type or edit selected items (when applicable). This pop-up menu lists all currently loaded line-types, each with its own index number.

The Line-type menu also provides the option to open the Line-type Manager pane of the Resource Manager window to manage existing line-types or to create new ones.

Arrowheads and Markers

Object vertices, such as lines, poly-lines, ovals, etc., can have arrows and other markers.

To set or edit the current object marker, use the two marker pop-up menus: the left one controls the start point of an object (Start arrow), and the right one controls end points (End arrow).

A slider on the bottom of the menu allows you to set the size of the arrowhead.

Pen Weights

Use this pop-up menu to set and edit the current pen weight from a list of 22 different values, expressed in millimeters.

To change an item’s weight, select it and choose the new weight from the menu.

Because of the resolution of the screen (72 dpi), pen weights cannot be displayed on screen exactly as they look on printouts; when the Actual (print size) Pen Weights mode is on, HighDesign displays the different pens on screen with an approximation to their real print size. When the Bitmap mode is active, pen weights are displayed with a simple progressive pixel size.

To change the way pen weights are displayed on screen, open the HighDesign Preferences window, select the Drawing pane and choose one of the three options available for pen weights or click the button on the lower right hand side of the main window.

In printouts with low quality paper, pen weights may be a bit different from those chosen on the menu. The optimal print resolution is 600 dpi on high quality paper.

Copy Properties

With this command all the properties of the selected item are copied and stored for later use. This function applies to layer, color, line-type, weight and arrowheads. Copied properties can then be applied to other items of the drawing.

This tool can also be used via a keyboard equivalent: Option-click an item to activate it.

Paste Properties

This command lets you apply previously copied properties to all the items you click on. When the pointer is over an item the cursor changes to a paint bucket: click to apply the properties to that item. Click in a void region to quit the Paste Properties tool.

This tool can also be used via a keyboard equivalent: Command-Option-click an item to activate it.

Styles and Types (Pro)

Definition of Styles and Types

A style is a named, predefined set of information, properties and behaviors that is possible to apply to graphic objects or architectural elements: when applying these presets to drafting objects we have Graphic Styles, whereas when applying a predefined set to an architectural element we create a Building Element Type.

Styles and Types define the common properties of a certain class of graphic objects or building elements. The specifications defined by a style or type are applied to all occurrences of that class in the project.

Graphic Styles

A graphic style stores the current settings of Layer, Pen and Fill Color, Arrow-heads, Line-type and Pen-weight: it can also include the settings specific to a class of objects.

Graphic Styles are classified as:

- Basic Styles. These are generic styles and can be applied to simple sketch objects, including construction objects, lines, poly-lines, rectangles and polygons, arcs, circles and ellipses and curves: existing basic styles can also be loaded by building element types as predefined graphic properties. Properties that are not supported in a class of objects are ignored (e.g. the fill color property is ignored by lines).

- Specific Styles, that apply only to specific drafting objects with their own tool settings; these styles are connected to the objects they are created for: when you select a specific style, the corresponding tool and method activate. Specific styles also include all the settings specific to their tool: for example, if you create a text style, it stores the current settings of the Text tool, such as font, size, alignment, etc.

Building Element Types

Architectural elements like walls, columns, doors and windows can get predefined sets of information, graphic properties and specific element settings: these templates that apply to new elements or to selected elements are called Building Element Types.

A building element type stores information such as name, tag and description, optional graphic properties which can be loaded from an existing basic style and the settings (geometry and options) of the current element.

Manage Styles

The Styles and Types pane of the Resource Manager is the main dialog to manage saved styles and types: use this panel to add selected styles to the project from the HighDesign Library or the User Library; this panel also provides the commands to create, duplicate, edit and delete styles.

The styles of the current project are managed via the Project Styles panel.

Project Styles panel

The Styles of the project can be quickly created and managed through the Project Styles panel: you can browse and manage the graphic styles and element types of the project, create new ones and remove styles from the project.

This panel marks selected objects or the current tool without a style as “No Style” on the top and lists all available Graphic Styles and Building Element Types of the project below: the current style is highlighted in this list.

The main commands of the panel are grouped as buttons in the bottom of the panel:

  • To create a new style push the “Add” button;
  • To remove the current style from the project push the “Minus” button;
  • To open the Styles and Types pane of the Resource Manager, push the corresponding button.The Add icon on the right of the Graphic Style section title opens the New Graphic Style window, whereas the Add icon on the right of the Building Element Type section title opens the New Building Element Type window.

It is also possible to open a drop down menu by clicking the triangle on the right of the name of a style to get some options of the current style.

Available options of the drop down menu are:

  • Duplicate Style/Type;
  • Edit Style/Type…;
  • Revert to Original Style/Type;
  • Select All Uses of “current style/type”;
  • Remove from Project.

New Style and New Type windows

The New Style and New Type windows display one or more panes arranged in different sections. The first pane shows the Identity section, which allows to set the information specific to the selected class of objects, and the Graphic Properties section to set the general properties that are also available in the Properties Bar.

The additional panes of the window can change, depending on the selected class, and present the settings sections specific to the current class of objects.

Create a New Graphic Style

The New Style window can be a single pane window if the selected class of objects does not have its Settings window: in this case the new graphic style is a Basic Style which stores just name and general graphic properties (Layer, Stroke color, Fill color, Line type, Markers and Pen weight); these properties are optional and it is possible for instance to create a graphic style with name, layer and stroke color only. A Basic Style is a general style and can apply to all graphic objects.

If the selected class of objects includes specific tool settings the New Style window is organized in panes corresponding to the sections of the Settings window of the tool: this graphic style is a Specific Style and stores general graphic properties and all the settings and options belonging to the current class.

In the Identity section of the New Style window it is possible to enter the style name and select the location of the new style:

  • “This project only” - selecting this option the new style exists in the current project only;
  • “User library” - this option saves the style as a file in the User Library folder on disk and in the current project as well.

Once created the new style is added to the list of the Graphic Styles section of the Project Styles panel of the current project. Select it to draw new objects with that style (these objects are called occurrences of the selected style). If the style is a Specific Style, the corresponding tool and method activate.

To apply a style to one or more objects, select the objects and click the style name on the Project Styles panel.

Create a New Building Element Type

The New Type window displays more options in the Identity section with the fields to enter Type Name, Tag and Description.

Also, the Graphic Properties section is optional and can be activated by clicking the switch near the section title. When this section is active it is possible to load an existing basic style through the Graphic Style menu and extract its graphic properties.

The panes of the New Type window display the settings sections specific of the current class of architectural elements: wall, column, door or window.

New types are added to the list of the Building Element Types section of the Project Styles panel of the current project and can also be saved in the User Library folder.

Edit a Style or Type

To change the settings of a style, such as its name, graphic properties or specific element settings, select it on the Project Styles panel and choose “Edit Style” or “Edit Type” from the drop-down menu and open the Edit Style or Edit Type window.

This window differs from the New Style/Type window in some details: it is not possible to select the location of the style and all fields and options show the settings of the selected style.

All changes made to a style automatically update all occurrences of that style in the project. If an occurrence of a style is modified, when selected it is marked as modified in the Project Styles panel. It is not possible to update or create a Style or Type by selection.

Revert a Style

When an occurrence of the current style has been temporarily modified by changing one of its graphic properties or settings, you can revert it to its original settings by choosing “Revert to Original Style” from the drop-down menu of the Project Styles panel.

Find all uses of a Style or Type

In the Project Styles panel open the drop-down menu of the style or type and choose “Select All Uses of [style/type name]”. All the instances of that style on the current sheet are selected.

Remove a Style or Type from the Project

Select the style or type on the Project Styles panel and click the “Remove from Project” button (–), or choose “Delete Style/Type” from the drop-down menu.

If there are any occurrences of that style in the project, a dialog lets you choose the “No Style” option or a new compatible style to replace the one you are removing. The objects whose style is replaced are updated to match the new style.