User Tools


7 Edit Objects and Elements

  • Functions of the Edit Menu
  • Modify Graphic Objects
  • Advanced Editing

Functions of the Edit Menu

The Edit menu is commonly used for standard commands like undo and redo an operation; cut, copy, paste and clear; select; search function; arrange and align items. It also provides the option to open the Tool Settings window.

Undo / Redo an operation

Most operations in HighDesign can be undone (and redone) up to 300 steps back, thus giving you the maximum freedom in experimenting.

“Undo” and “Redo” apply to the following actions:

- Creation of new items (e.g. new Line, new bézier, etc.) - Deletion of one or more selected items - Modification of selected items (e.g. extend, modify, trim, drag, etc.) - Complex operations (e.g. fillet, chamfer, paste, etc.)

In particular situations, it may be useful to suspend the action logging system used by the Undo/Redo commands to save RAM. The Suspend Undo allows to temporarily put the Undo engine to pause.

Cut, Copy, Paste and Delete

These are standard functions you find in all programs and provide some simple yet useful actions:

- Cut means that selected items will be deleted from the drawing and put in memory for later use; - Copy means copying the selected items to memory, without removing them from the project; - Paste lets you insert items stored in memory; - Delete is used to erase selected items from a project.

Objects copied from HighDesign are not stored in the system’s clipboard, but rather use an internal copy and paste method, so that the system clipboard is available for images and texts.

The Paste command opens a dialog with options that allow to choose the source from which to paste the objects, whether the system clipboard or the HighDesign clipboard. Other options include the location of the pasted object and the destination layer.

Copy as Image

The Copy As Image menu items let you copy the selected objects as image into the system clipboard, for use in other graphics software. The objects are copied as images in one of the following formats and resolutions:

- PNG at 72 DPI - PNG at 300 DPI - PNG at 300 DPI with alpha channel - JPEG at 72 DPI - GIF

The objects are copied at the current zoom factor, and the higher the resolution, the more memory is required to create the image. Since projects in HighDesign are made of vector elements that can be zoomed in almost indefinitely, it is possible to run into low-memory situations when copying a large project as image. Reduce the zoom or copy one area at the time to work around possible hardware limitations.

Selection

The Edit menu includes commands to quickly select items with some conditions. Apart from the “Select All Sheets” command, all selection functions apply to the current sheet. The selection commands follow the state of layers, and items on hidden or locked layers are not selected.

- “Select All Sheets” selects all elements on all drafting sheets; - “Select All” command selects all the elements on the current sheet; - “Select Current Layer” to select all the objects with the current layer; - “Select All <object type>…” selects all the elements on the current sheet of the same type as the currently selected drawing tool; - “Invert Selection” selects all the elements and deselects those that were already selected; - “Deselect” deselects all the currently selected items. - Restore Last Selection: restores the last used selection even after having been deactivated.

Drawing items can be selected either via the Arrow tool or by pressing the Shift key and clicking the item or clicking with the right button of the mouse. See also “Arrow and Selection” paragraph on chapter 5.

Search Functions: the “Find” command

To search items within a project select Edit ▸ Find… to open the “Find” window. The Find dialog lets you search items within the current sheet setting criteria to reduce the scope of the function.

The upper section of the Search window shows the buttons corresponding to the graphic objects you want to find within the currently selected sheet. These objects are arranged in three groups: Drafting objects, Documentation objects and Architectural elements.

The optional search criteria offer the menus and fields needed to filter the search.

Search Criteria:

- Object Type: push the button corresponding to the object type you want to find; - Sheet: select the sheet (drafting sheet, detail or layout); - Style/Type: search items with a style or type; - Layer: search items within the selected layer; - Pen Color: edge color of the objects to find; - Line-type: edge line type of the items to find; - Pen Weight: pen weight of the items to find; - Text: search for all occurrences of the text in the drawing; - Tag: enter the known tag to search elements with that tag; - Name: enter the name of architectural elements; - Description: enter the description to search matching architectural items.

You have three options: select all the items matching the active criteria (“Find All”); select only one matching item (“Find Next”). By checking the “Zoom To Selection” option you can have the page automatically scroll to center the view to the selection.

Arrange

Drawing objects are displayed to screen (and print) with the creation order: the first item created is behind all others. If you place an opaque fill over other items, it will cover everything behind it.

It is possible to change this order by sending back or to the front the selected items by using the options in the Arrange sub menu of the Edit Menu:

- “Bring to Front” sends the selected item to the front of all other items; if the selection contains two or more items, they are moved with their internal order; - “Bring Forward” moves the selected items up one position; - “Send Backward” moves the selected items down one position; - “Send to Back” moves the selected items to the back of all other items.

Align

This command moves the selected objects sorting them by their position and the chosen rule. Alignments by a direction use the first object in that direction among the selected objects. For example, Align to Left Margin uses the left-most point of all selected objects as left alignment margin.

The alignment rules are:

- Left margin; - Center in column: aligns the objects vertically; - Top margin; - Center in row: aligns the objects horizontally; - Bottom margin.

Distribute

Every object has a bounding box that defines the maximum extents of its dimensions. The Distribute command allows you to position the selected objects according to the space between the bounding rectangles. The first and last objects in the selected direction define the margins.

The options are:

- Left Margin - Center in Row - Right Margin - Horizontal Spacing: - Top Margin - Center in Column - Bottom Margin - Vertical Spacing

Edit Graphic Objects

Move

Use this function to move selected items. Choose Drawing ▸ Move, then click to set a start point, move the pointer and click again to set direction and offset of the translation.

- Applies to: selected objects - Steps:

1. define the start point, origin of the translation; 2. define the end point.

- Available Constraints:

- Length (L + value; value) - Angle (A + value)

By holding down the Alt key, the Move tool turns to Duplicate. The Move command can be activated in other ways too:

- With the Selection tool, or during the editing of an object, by clicking the center point if available; - With the Arrow keys, or Shift + Arrow key if set in Preferences ▸ Workspace, to move the selected objects by one linear unit; holding down the Alt key the offset is multiplied by 10. - Holding down the Cmd key, you can click on an object and begin a Move command with one operation.

Duplicate

This function creates a copy of the selected items with a defined offset.

The Duplicate function can also be activated by the Arrow tool by pressing the Option key while moving selected items.

Hold down the Command key to make multiple copies of the same selection in one session.

- Applies to: selected objects - Steps:

1. define the start point, origin of the translation; 2. define the end point.

- Available Constraints:

- Length (L + value; value) - Angle (A + value)

Linear Multiply/Distribute

This function creates a number of copies of the selected items. The method can be Increment, where the distance between start and end point define the distance between each copy, or Distribute, where the distance defines the maximum width of the copies. With this option, the distance between the copies is calculated on the number of copies.

- Applies to: selected objects - Steps:

1. Set number of copies and method, Increment or Distribute;

2. define the start point, origin of the translation;

3. define the end point.

- Available Constraints:

- Length (L + value; value); - Angle (A + value)

The Multiply/Distribute dialog can be used entirely with the keyboard: the Up and Down arrow keys control the number of copies; Command + Up/Down arrow controls the option buttons.

Polar Multiply/Distribute

Use this tool to create multiple copies of selected objects along a circular arc. The menu item Drawing ▸ Polar Multiply opens the input dialog used to enter the number of copies and select between increment and distribute.

- Applies to: selected objects - Steps:

1. Set number of copies and method, Increment or Distribute; 2. define the center of the rotation; 3. define the start point of the arc 4. define the end point of the arc.

- Available Constraints: Angle (A + value)

The Polar Multiply/Distribute dialog can be used via the keyboard: the Up and Down arrow keys control the number of copies; Command + Up/Down arrow controls the option buttons.

Rotate

This function lets you rotate selected items around a central point and by an angle you define graphically.

- Applies to: selected objects - Steps:

1. define the first point, center point of the rotation; 2. define the start point; 3. define the end point and angle.

- Available Constraints: Angle (A + value)

You can also enter a rotation angle value by pressing the “A” key on the keyboard between steps 2 and 3.

Rotate by Angle

Use this tool to rotate the selected objects in real time. The center of the rotation can be absolute, which is the midpoint of the bounding box of the selection, or the center of the object, which rotates each object around its own center.

- Applies to: selected objects - Steps:

1. In the Rotate By Angle window, set the angle by using the slider or entering the value into the input field; 2. Choose between global center of the selection and individual object center.

Mirror

This command transforms objects by mirroring the selection around an arbitrary axis:

- Applies to: selected objects - Steps:

1. define the start point, origin of the axis; 2. define the end point, angle of the axis.

- Available Constraints: Angle (A + value)

Mirror and Duplicate

Just as Mirror, this function creates a mirrored copy of the selected items. The procedure is the same as the “Mirror” command described above.

- Applies to: selected objects - Steps:

1. define the start point, origin of the axis; 2. define the end point, angle of the axis.

- Available Constraints: Angle (A + value)

Stretch

Use this command to pull and resize the objects within the selection rectangle: items which are entirely within the selection rectangle will be moved whereas all other objects will be resized. Arcs, circles, ellipses, text blocks, doors/windows and symbols will be rigidly dragged with no change of shape.

- Applies to: selected objects - Steps:

1. define the start point, origin of the translation; 2. define the end point.

- Available Constraints:

- Length (L + value; value) - Angle (A + value)

Resize Drawing

Use the Resize Drawing tool to change the size of the drawing by a per cent value or by numeric values of width and height. The dimension can be made independent or proportional by clicking the lock icon. The values can be entered in percentage or in any of the supported linear units.

By activating the Resize entire drawing by selection checkbox, the entire drawing will be resized by the same amount applied to the selection. This is particularly useful when the drawing is not at scale (usually an imported drawing or an inserted image file) and you need to scale it. In this case, you can select an item of known size, open the Resize Drawing window, activate the checkbox and enter the real values. The entire drawing will be resized accordingly.

- Applies to: entire drawing / selected objects - Steps: enter one or both values of size - Available Constraints: proportional values

Mark Intersections

This function finds all intersection points between two selected items. Supported intersections are:

- Applies to: selected objects - Steps: direct command

Join

This command extends two selected lines or walls to their intersection: if the lines did not intersect, they are extended; if they intersected each other, the functions shortens them to the point of intersection.

This command cannot be applied to parallel items.

- Applies to: selected objects - Steps: direct command

Extend

This function extends the selected lines (either by lengthening or shortening) to their intersection point with another object. Supported types are:

Construction line, Line, Polygon, Rectangle, Freehand line, Bézier curve, Arc / circle, Wall.

- Applies to: selected lines or walls - Steps: click on the destination object

Split

This function splits into segments lines intersecting other lines, poly-lines, rectangles, hatches, arcs, circles, freehands and bezier curves:

- Applies to: selected lines - Steps: click on the destination object

Trim

The Trim function is a multipurpose function designed to delete linear or curved segments or parts. It applies to single segments without intersections with other objects as well as to segments intersected by other objects.

Segments without intersections

Activate the tool and click on the segment to delete: if the trimmed segment belonged to a rectangle or polygon, the remaining segments are turned into poly-lines.

Segments intersecting other objects

Activate Trim and click on the segment or part of segment to delete: use this tool to clear a drawing and cut segments, arcs and curves between intersections or extending off an edge with just a click.

To apply it:

1. Choose Drawing Trim or click on the corresponding icon of the Edit Tool Bar; 2. A visual aid highlights the segments under the pointer (1); 3. Click the parts of the objects you want to trim; 4. All segments and portions of arcs between intersections or extending off the edge will be deleted (2); 5. Click an empty region to quit this command or press the Esc key.

You can also activate the Trim command by holding down the Backspace or Canc keys on the keyboard and clicking the object, or by clicking with the eraser tip of a graphic pen. No selection is required to use this function.

When activated with a selection, the selected objects acts as “cutters” and control the intersections. All intersections that do not belong to a selected object are ignored.

- Applies to: objects at click - Steps: click on the destination object

Divide into Parts

This command is used to divide the selected line into the number of equal segments you specify in the Divide Into dialog. This dialog lets you also choose whether divide the line with datum points or actually create segments.

The Divide Into dialog can be used via the keyboard: the Up and Down arrow keys control the number of divisions; Command + Up/Down arrow controls the option buttons.

- Applies to: selected objects - Steps: set the number of parts

Break

This tool allows you to define a segment that will be subtracted from a selected line. Select Drawing Break, click on a line to set the first point of the segment and click again to set the endpoint.

- Applies to: selected objects - Steps:

1. define the first point; 2. define the second point.

Modify Project Elements

Fillet / Chamfer

These commands allow to join two segments, lines or poly-lines, by an arc with a given radius, or by a chord with a given length. There are two ways to use these tools:

Numeric:

1. Select two non parallel segments; 2. Choose Tools Fillet or Tools Chamfer or click on the corresponding icon of the tool bar; 3. A text field shows up near the tool icon: insert the value of the radius or the length of the chord and push Enter.

Graphic:

1. Select two segments; 2. Choose Tools Fillet or Tools Chamfer or click on the corresponding icon of the tool bar; 3. Click on the white handle of the radius/chord and move the pointer along the constrained direction perpendicular to the radius/chord to resize its length; 4. Click again to confirm.

When applied to poly-lines, you can change the vertex to modify by placing the cursor over the vertex and wait for a second until the preview updates.

Offset

This tool is used to create concentric duplicates of linear objects (lines, polygons, rectangles, poly-lines, freehands, arcs, circles and ellipses) at a given distance.

To activate the command, select the objects and go to Tools Offset: enter the distance in the text field showing up near the tool icon, then click on the white handle and move the pointer to choose the side you want to place the duplicate on.

Click on the other objects if you want to apply the command with the current settings to other items. Press ESC to conclude the command.

2D Extrude

This graphic function simulates the extrusion along a direction of selected objects by creating generatrices from the vertices and a duplicate of the selection.

Explode

Most of the drawing objects, such as polygons, poly-lines, freehand lines, Bézier curves, arcs and circles, ellipses, hatched polygons, symbols, walls, windows and columns, can be converted to simpler items by the Explode command.

Select the items you want to simplify and choose Tools Explode: all the selected items are converted to lines and the source object is deleted. Symbols are converted to their base items.

Convert into Poly-line

Use this command to convert the selected and connected objects (lines and arcs, regular polygons and rectangles) into poly-lines.

Apply Hatch

This command applies a hatch or fill to the region described by the selected items. Supported boundary items are:

- Lines connected by their vertices (“segmented lines”); - Poly-lines; - Polygons; - Freehand lines; - Bézier curves; - Splines; - Arcs; - Circles; - Ellipses

To use this tool, select the boundary items, then choose Tools Apply Hatch: a new fill/ hatch is created with the current settings of the “Hatches and Fills” tool.

Calculate Area

This function calculates the area of a region enclosed by the selected items. Supported boundaries are:

- Lines connected by their vertices (“segmented lines”); - Poly-lines; - Polygons; - Freehand lines; - Bézier curves; - Splines; - Circles, arcs, ellipses.

To use this command, select the boundary items, then choose Tools ▸ Calculate Area: a new text label displaying the area of the region in the current units is created in the center of the selection.

Calculate Center of Mass

The function “Find Center of Mass” calculates the position of the center of mass of the selected polygons, closed poly-lines or hatches. To calculate the center of mass of curved regions like circles or béziers, you can explode them and then apply this command to the selected lines.

Tangents to Two Circles

This tool finds four points that define the lines tangent to two circles. To use this command, select two circles or circular arcs, then choose Tools Tangents To Two Circles.

Fit Text box to Contents

When you change font or style to the paragraph or even when you import texts from other applications, the text box can be larger or smaller than its actual content: this command adjusts the size of the selected text boxes.