User Tools


5 Drafting Tools

  • Basic Drafting Skills
  • Arrow and Selection
  • Construction Objects
  • Lines
  • Poly-lines
  • Rectangles and Polygons
  • Hatches and Fills
  • Circles, Arcs and Ellipses
  • Curves
  • Symbols
  • Images
  • Groups

Basic Drafting Skills

To start drawing with HighDesign you select the tool you wish to use and set its graphic properties if needed.

Many drafting tools have specific tool methods, available as tool options in the Methods Bar and also by a click on the triangle on the right of the tool icon. Select the method you wish to use by a click.

Hatches and Fills and Symbols, like most of the documentation and design tools, have special tool settings available in their settings windows: double click the tool icon to open its Settings window.

Drawing Techniques

In addition to the mouse, HighDesign supports trackpads and pen tablets, specially useful when tracing a drawing over an image.

The default drawing procedure adopted in HighDesign is “Click-Move-Click,” i.e. to draw a line you click to set the start point, move the pointer to the desired location and click again to set its end point. Click-drag is also supported. You can change the drawing method in Preferences ▸ Drawing.

Some tools, like the Polygon tool, need a double-click to set the end-point.

To cancel an operation you can hit the “Esc” button on the keyboard, or press the right button of the mouse.

The general drafting procedures described above are also valid for Drafting, Documentation and Design tools as well.

Arrow and Selection

The Arrow tool lets you select drawing objects by clicking directly on them or by dragging a selection rectangle. To select an object, click on it with the arrow tool. Snap to Objects must be active so that the arrow tool can “see” the object you are clicking.

Press Shift while clicking to add items to the selection or remove already selected items. Click on a blank part of the screen to deselect all.

Methods

Rectangular selection:

click on a blank part of the screen and drag the pointer to draw a rectangle: objects with control points within the rectangle will be selected.

Polygonal selection:

this function allows the user to select objects with the control points within the polygon drawn by clicking on its vertices.

Both Rectangular and Polygonal selection can be used in two ways: “Inclusive”, which is the normal way and selects all the items that have at least one control point within the selection area; “Exclusive”, which can be activated by pressing the “Option” key, has a dashed outline and selects only the items that have all control points within the selection area.

With the rectangular selection, it is possible to make an exclusive selection by tracing the selection rectangle from bottom to top. In this case, holding down the Option key switches between inclusive and exclusive. Holding down the Shift key while using the selection rectangle adds to or removes objects from the selection. If the option “Arrow tool clicks extend selection” is active, clicking an unselected object will automatically add it to the selection.

Select overlapping objects

When two or more items overlap it can be difficult to select the right object. To get a smart selection, activate the Arrow tool, hold the Control key and click or right-click on the intersection to open a contextual menu listing all the objects top to bottom.

Select the desired object by a click on its name on the list.

The Arrow tool can also be used as an all-purpose editing tool: most of the tool-specific editing actions, such as resizing a line or editing a text, can be performed with the Arrow tool. Clicking a selected object on its outline, but not on a vertex, will activate the Move function. Hold down the Command key to move any object, selected or unselected, by any of its vertices or by its outline.

Construction Objects

The Construction Objects tool can be used to mark reference elements and auxiliary objects in the drawing. It has three modes: point, to create reference points in the drawing; construction line, to add infinite lines for alignments and margins; origin, to set the origin of the coordinate system in the current drawing.

Methods

Datum Point:

click on the desired location to insert a point or press the X and Y keys on the keyboard to enter its coordinates. In the Print window you can choose to print datum points and construction lines.

Construction Line:

allows you to create infinite lines: click to set the center and direction or enter the angle by pressing the A key on the keyboard or click an existing linear object to draw a parallel construction line. To set the distance of the construction line from the reference linear object, press the L key on the keyboard, enter the value and click on the desired location.

Construction lines can also be drawn as horizontal and vertical guides: drag them from the rulers to the desired location. Construction lines can be moved with the Arrow tool.

Absolute Origin:

click to change the origin of cartesian axes and rulers. The coordinates of the drawing and dimensions are updated automatically. You can also change the Origin by using the button on the intersection of the rulers. In HighDesign Professional each sheet has its own Origin.

Lines

Probably the most used tool, the Line tool allows you to trace straight lines of any length and angle from a start point to an end point.

Methods

Single Line:

draws the line from one endpoint to the other.

Line by Center:

this method creates lines by midpoint and half-line.

Segmented Line:

click to set the first vertex, then click to set the next vertex. To end the path, double-click on the last vertex. Each segment is a separate line.

Double Line:

this method creates two segments of the same length and angle with an offset you set by entering the value on the “Offset” field next to the methods icons. Double lines can be traced from the axis or from one side.

The standard procedure to draw a line of a given length is to set the first point, push the “L” key (or the corresponding shortcut), enter the value and push the Return key. The same procedure applies to Angle (A), X, Y.

To resize a line, select it and with the Line tool active click one endpoint. Click its midpoint to move.

Poly-lines

The Poly-line tool is used to create a polygonal shape made of a connected series of straight and curved segments. Curved segments are arcs drawn by center or by tangent.

To draw a poly-line, click to set the first vertex, then click to set the next vertex. To end the chain, double-click on the last vertex.

While creating a poly-line, an action icon follows the start point of each segment. Click it or hover on it to open the options menu and choose the type of the next segment, delete the last segment or end the shape. To close the poly-line, select the corresponding option or place the last vertex on the first one. Poly-lines have the fill option available in the Properties Bar.

Modify a Poly-line

A poly-line can be edited in many ways: activate the Poly-line tool and select the object (if it’s not already selected); then you can click on a side to add a vertex, drag one vertex to change its position or place it over another vertex to delete a side. You can also hover the cursor on a vertex to open the edit menu with the options to delete the vertex or add another one at the midpoint of the previous segment. In the Object Info panel the Convex control slider allows to change the convexity of the curved segments of poly-lines: activate the start point of the curved segment using the arrows in the Point section of Object Info to display the convexity value in percentage and move the slider to change it.

The Radius value is automatically updated when using the convexity control: you can also set the radius value numerically.

Rectangles and Polygons

Use this tool to draw rectangles, squares and regular polygons of any number of sides. Rectangles and Polygons have a fill property with color and transparency: choose edge and fill color on the Properties Bar.

Methods

Rectangle:

to draw a rectangle, click to set the first vertex, move the pointer and click again to set opposite vertex. You can add diagonals to a rectangle by pressing the Option key on the second click. To draw a square, use the rectangle tool and hold the Shift key to constrain the diagonal direction.

To set the size of the rectangle, click to set the starting vertex, then push the “W” key to set the width and “H” to set the height. Positive values go rightwards and upwards. To edit the rectangle with either the Arrow tool or the Drawing tool active, click on vertices to resize, on midpoints of sides to stretch, and click on sides or center point to move.

Rotated Rectangle:

click to place the first vertex, move the pointer and click again to set the base angle; then move the pointer and click a third time to set the height of the shape.

To set the dimensions, click the first vertex, push the “A” key to set the angle, the “W” key for the width and the “H” key for the height.

Rectangle by Center:

click to set the center of the rectangle; move and click to define the orientation and the first axis; move and click again to define the perpendicular axis.

Regular Polygon by External Radius:

this method allows you to draw regular polygons with any number of sides starting from three. To set the desired number of sides, use the offset field in the Methods bar next to the tool methods and insert the value.

To draw a Regular Polygon by the external radius, click to set the center of the shape (all these regular polygons are inscribed in a circle), move the pointer and click again to set the radius of the circle circumscribed and the vertex of the polygon.

Regular Polygon by Internal Radius:

this method lets you draw the polygon by setting the center and the radius of the circle inscribed in the polygon.

Regular Polygon by Side:

to create the polygon, draw the first side, exactly like a line of the desired length and angle, and click again to place the shape at the desired location.

Hatches and Fills

Use the Hatch tool to fill polygonal regions with a color, with a linear vector hatch or a tiled vector pattern. This tool has three methods: Hatches, Polygonal Islands and Circular Islands.

Hatches can be chosen from a list of types: HighDesign comes with a wide range of built-in hatches that can be easily extended with your own hatches. You may also combine fills and hatches.

To set or edit hatch attributes, select Edit ▸ Settings Window ▸ Hatch Pattern or double-click the corresponding icon in the Tools bar to open the Hatches & Fill Settings window.

Hatches and Fills Settings Window

The Settings window displays all options for the graphic properties specific to the tool and the controls and fields for tool setup.

On the top bar of the dialog, close to the title, is available the triangular button to select and load existing styles: on the right there is the Add icon which allows to create a new style by the current settings. These general features of the title bar of the Settings window are shared by all drawing tools with specific settings.

The Settings options are:

- Border: select to show the border of the hatched region and select its color. - Fill: select to add a solid color or gradient fill. Use the fill color button to select the color and options. - The Hatch/Texture checkbox enables the vector hatching of the region; the color of the hatch can be selected via the Pen Color menu on the Properties bar. - Scale Factor: use this slider to scale spacings and offsets of the hatch or to resize the tile of the texture. - Draw at scale: adjusts the scale of the hatch to match the current sheet scale, so as to resize the hatch accordingly. This option is especially useful when the hatch represents an actual construction element like a floor or a wall. - Rotation: controls the rotation angle of all the patterns of the hatch. Textures can only rotate by 90 degrees. - Hatches table: lists all installed hatch types, including any custom types. - The last cell of the Hatches table is a special button: click it to add hatch types to the current project. This option opens the “Hatch patterns” pane of the Resource Manager window.

Draw and Edit a Hatch / Fill

To draw a Hatch/ Fill region, use this tool in the same manner as the Poly-line tool or select an existing polygon and choose Tools Apply Hatch. While drawing a Hatch / Fill region, it is possible to delete the last vertex with a click on the X icon close to it.

To edit a vertex of a hatch region, select the object and, with the Hatch tool active, move the pointer over the vertex till the tool menu shows up with the edit options.

To add a vertex, click on one side or click on the “Add Vertex” option of the menu; to erase a vertex, move the pointer over that vertex and click on the corresponding option of the tool menu.

The “Fit arc at click” option shows up when the pointer is over the start point of an arc and allows the user to edit the selected hatch and fit the arc with a click on it.

Methods: Hatch insertion and Islands

Hatches can also be inserted on homogeneous shapes with a click on their outline. Hatches and Fills can host multiple openings of polygonal and circular shapes. These openings are called islands and there are two different tool methods to create them.

Methods

Hatch at click:

It is possible to apply the current hatch to homogeneous shapes such as Poly-lines, Rectangles, Polygons, Circles, Arcs, Ellipses, Free-hands, Curves with a click: just activate the method and click on the outline of the shape you wish to hatch. Regions enclosed by connected walls can be hatched with a click inside.

Polygonal Islands:

Select this method to create polygonal openings in existing hatches by drawing the shapes of the islands within the selection. To do this, just activate the Hatches & Fills tool, select the method and click on the vertices of the polygonal opening you wish to create within the hatch. This method can be used on either selected and unselected hatches. The nearest hatch is detected automatically as you move the cursor over the project.

Circular Islands:

This method allows you to open circular islands defined by center and radius. Click to set the center and click again to set the radius: it is also possible to set the value of the radius numerically.

To edit the island, select the hatch and locate the pointer over one vertex of the opening till the tool menu shows up giving you the options to remove the island, to delete one vertex or to add another one.

Circles, Arcs, Ellipses

Use this tool to draw circles, arcs, ellipses and arcs of ellipse. All the methods for circular arcs can be used to draw full circles by clicking the switch that appears on the screen next to the first point of the arc, or by holding down the Alt key.

The construction can be both graphical, via clicks on the drawing, or numerical via the keyboard input.

Methods

Arc/Circle by Center and Radius:

to draw an arc or circle click to set the center (or set it with by coordinates), then select the arc or circle option on the on screen floating button.

To draw an arc, set the radius by pressing the L key, set the start angle by pressing the A key and set the end angle by pressing A again. To draw an arc graphically, move the pointer and click again to set the start angle; with the next click you define the end angle of the arc.

To draw a full circle, set the length of the radius by pressing the L key on the keyboard and the start angle / end angle by pressing the A key. Press Return to confirm.

Arc/Circle by Diameter:

click to set the first vertex of the diameter, move the pointer and click again to set the second vertex. You can define the diameter by pressing the L key, and the angle by pressing the A key.

Arc/Circle by Three Points:

click to set the points that define the arc. The three points can also be defined via numeric input using the X, Y coordinates or L and A values.

Arc/Circle by Tangent:

click on the endpoint of a line or on the endpoint of an arc to set the first point of the arc drawn by the tangent to that object at that datum endpoint.

Ellipse by Bounding Box:

set the start point, move and define the end point of the diagonal. The ellipse is inscribed in the rectangle defined by its diagonal.

Ellipse by Center and Radii:

click to set the center of the ellipse, move and click to define its first radius; move again and click to set its second radius. The center can also be defined by using the X, Y coordinates and the radii can be defined by pressing the L key during their construction.

Quarter of Ellipse:

this method allows you to draw quarters of ellipse by clicking on its two vertices.

Curves

The Curves tool allows you to draw freehand lines, single and multiple Bézier curves, Spline curves and clouds.

Methods

Freehand Line:

use this method to trace non-regular curved lines: they are specially useful to add your personal touch to a drawing, trace over images and everything else you would do “by hand” such as terrain levels and archaeology surveys.

Freehand lines are smoothed, that is over-defined segments will be simplified once the line is drawn, thus reducing its complexity and making it quicker to be redrawn on screen. You can adjust the smoothing factor of freehand lines in the Preferences window ▸ Drawing pane: 0 means that the line will preserve its original shape, but might contain many vertices; 5 is the maximum smoothing and the line will change slightly its shape, but will be a lot faster to redraw and have a more regular appearance.

In the same pane, you can also choose to draw freehand lines with a click-drag method instead of the standard click-click: this option is specially useful when used with a pen tablet, because it allows a more natural way of drawing with a pen.

Bézier Curves:

this method can be used to draw parametric curves defined by two vertices and two tangent lines.

To draw a Bézier curve, click to set the first vertex, move the pointer and click to set the next vertex; this method allows you to draw multiple, connected Bézier curves: this way the first tangent of the next curve is always defined by the previous one. Double click to end the chain of Bezier curves. Bézier curves with only two vertices looks like a straight segment: edit the tangents to adjust its shape. Bézier curves have the Fill property: select the desired color on the “Fill color” menu of the Properties bar.

Edit a Bézier curve

- By clicking on one of the four control points of a selected curve, you can change its position and visually adjust the profile. With multiple Bézier curves, by editing a definition point the connected tangents are constrained to keep the same angle: move the control points of the tangents to change the angle and adjust the shape of the curve. - Hold down the Alt key while moving the control points of the tangents to edit asymmetrically; Alt key + Cmd key to disconnect the tangents.

Spline:

Spline curves in HighDesign are cubic B-spline, continuous curves drawn through a given set of points: to create a spline curve, click to set the points that define the shape of the curve. Double click on the last point to end the curve. Choose the fill color from the corresponding menu of the Properties bar.

Edit a Spline curve

- To edit a Spline curve, once it is selected, move the given points with the Arrow tool or with the pointer and the Spline tool method active.

Revision Cloud:

with this method you can create a group made of chains of connected arcs. You can use this tool to draw a personal set of revision clouds to be saved as symbols for future uses.

Symbols

The Symbols Tool is a drawing tool which allows you to put in your project entire drawings or portions of drawings already created and stored in a library with just one click. Using Symbols is a convenient way for reproducing many times the same group of elements with independent rotation, mirroring and scale factors.

Symbols can store attributes, which are information displayed at the desired location of the current view.

To edit or set the Symbol Tool properties, select Edit ▸ Settings Window ▸ Symbol or double-click the Symbol Tool icon in the Drawing Tools bar.

Symbol Settings Window

The Symbol settings dialog has two panes: Symbol and Attributes. The Symbol pane provides you with many options to choose a new symbol and set its graphic properties.

- The table lists the currently selected library folder: this folder may contain many sub folders and can be organized at your choice. Browse through this table to select the symbol file. - Once a symbol has been selected, a lists all of its views shows up if available: select a view from the list to activate it; double-click its name to change it and click on the pencil icon to edit the symbol/ view (for custom symbols only). - The preview box displays a thumbnail of the selected symbol with the current parameters. - Symbol geometric parameters are: width, height (which can resize proportionally), angle (in degrees); Below the input fields, the Quick transformations buttons enable the mirroring of the symbol. Symbol properties are the fill and color options and the option to scale the symbol correspondingly to the current drawing scale. - On the bottom are grouped the buttons to (from left to right) create a new folder, create a new symbol from selected objects, duplicate the selected symbol, add a new view to an existing symbol and delete the selected item.

The Attributes pane displays the optional attributes of the current view. Use this pane to set the values of the attributes of the symbol or symbol view you are inserting in the project or to change the values of the current selection.

Create and Edit Symbols

The “New Symbol” and the “Edit Symbol” functions, also available through the Project menu, when activated switch to a different workspace with a limited set of tools: in this environment you can draw, modify and save symbols and symbol views.

You can either create a new symbol from scratch or create a new symbol from the selection: in this case you can also activate this function through the Radial Menu for a quicker workflow. This way the selected objects are now visible in the “Edit Symbol” environment whereas all the other elements of the drawing are hidden.

Create a new symbol:

1. Select “New Symbol” on the Project menu; 2. The Environment turns to the “Edit Symbol” context with a limited set of tools and the “New Symbol” dialog opens; this dialog is divided into four sections:

- Symbol Name; - View; - Attributes; - Insertion Points.

3. Draw the symbol; 4. Type the symbol name; 5. Select the destination folder through the folder button; 6. Use the “+” button to add a new view; 7. Type the view name; 8. Set the attributes; 9. Insert the attributes in the drawing of the symbol view; 10. Place the Insertion Points on the desired locations of the symbol view; 11. Press the “Save” button on the dialog.

Attributes of the Symbol

Attributes are information added to the current view of the symbol: these information are defined by an ID, a Prompt, showing on screen, and a Default value which will be displayed in the project.

The Attributes section of the New Symbol dialog shows:

- The menu of the existing attributes of the view (visible when editing a symbol and its attributes); - The Add button to create a new attribute; - The button to remove the selected attributes, - The “Edit attribute” button to modify the currently selected attribute.

Since attributes are a sub-class of text, they can get text properties such as font, font size, alignment, style and rotation angle: the “Define Attribute” window displays all these information and options.

To insert the attribute, just click on the desired location of the symbol view.

Edit a Symbol

To edit a symbol you can click on the Edit button of the selected symbol on the Settings window, or select the symbol on the drawing and either choose “Edit Symbol” on the Project menu or use the Radial Menu.

The “Edit Symbol” workspace opens and you can modify the symbol, add views to the symbol by pushing the “+” button of the dialog or delete views through the “-” button, change the attributes of the view and add or change insertion points.

By pushing the “Save” button, the environment turns back to “Drawing”. Changes made to a symbol are immediately visible in all the symbol duplicates of the drawing.

Insert a Symbol into the drawing

- Open the Symbol Library dialog by choosing Edit ▸ Settings Window ▸ Symbol or by double- clicking the Symbol icon in the Drawing toolbar; - Select a symbol in the Folders table and choose one of the available views; - Set its size and optional parameters; - Review or change the default attributes if available; - Click one of the defined insertion points, the center or one of the vertices or midpoints of the thumbnail to select the current insertion point; - Either drag the preview to the drawing or click on the desired point of the drawing.

To create a new symbol, to add a view to a symbol or to edit an existing symbol, are also available the specific commands on the Project menu.

Images

Images in HighDesign can be inserted via the “Insert Image” command on the File menu or via the Insert Image tool settings window. Supported file types are TIFF, JPG, PNG, GIF and PDF. Alpha levels present in TIFF and PNG files are preserved.

You can also drag an image from another program, such as a web browser, or a file directly onto the drawing canvas.

Insert an Image

HighDesign lets you easily add pictures to your project from several graphic formats (TIFF, JPEG, PNG, GIF, PDF). Images inserted into the project keep their resolution and are displayed at the real print size: it is also possible to handle them as any other vector entity. PNG and TIFF images are imported with their alpha channel if present.

To insert a picture in your project, select File ▸ Insert Image…, choose the image and place it at the desired position with a click. You can also open the Image Settings window by double-clicking the Insert Image tool in the Project Tools Bar and push the Open Image button. Alternatively, you can drag an image from another application, such as a web browser, drag a file directly onto the drawing canvas, or use the Paste command to paste an image from the clipboard.

PDF documents can be inserted as high-resolution images. When you choose a PDF document with the Insert Image command, you are presented with a dialog where in you can select the page to import, if more than one, and set the resolution at which the image object will be created.

If you use the Pro version of HighDesign, you can also enhance the image by adjusting brightness, contrast, saturation, size, sharpness, smoothing factor, etc. To set size on screen, print size, resolution and transparency of images, use the Image Settings window on the Edit menu.

Images can be moved, resized and rotated, either via the editing tools, the Object Info panel, or the Image Settings window.

Image Settings Window

The Image Settings window displays the Image Preview and provides the following options:

- Size: the dimensions of the selected image object in the project, measured in points, millimeters, inches or percentage; - Image Resolution, in Dots Per Inch. - Display at screen resolution: when this option is active, the image is always displayed at the resolution of the screen, which is typically lower than paper. The visible size of the image is larger at lower resolutions. - Transparency: sets the amount of transparency the image is displayed at. Values range from 0%, totally opaque, to 100%, totally transparent. - “Restore Original Values” button, to reset image size and resolution as in the source image. - File Format: images are handled like other vector objects and saved in the project file. The internal format can either be PNG, which preserves the full quality of the image, or JPEG, which compresses the image and saves file size considerably, but reduces the quality. JPG is very good for photographic images, but not for images that contain line drawings, such as city maps or scanned drawings.

Image Size and Resolution fields allow numerical changes. Please note that the Size/Resolution ratio is constant and therefore, when changing the size, the resolution will change accordingly and vice versa.

Use the “Info” button close to the Image Preview to show the information of the source image on its preview canvas. Provided information are: file size, creation and modification dates, location of the file, image dimensions expressed in pixels and its resolution.

When the pointer hovers over the Image Preview the “Replace Image” button appears: click on it to select a new source image to insert within the existing image box.

Groups

HighDesign provides the ability of grouping different objects together as a single item. Most editing operations and transformations can only be applied to selected items, either to individual objects or to a group of objects at once.

Groups are a convenient way of organizing items by binding heterogeneous items in one “collection” which behaves as one object. Once a number of drawing objects are grouped together you can select them simply by clicking any of the group members. By default, the grouped objects retain their attributes, such as color, line type, weight, etc. Changing the attributes of a group applies the changes to all its members.

Group functions of the Project menu

All commands connected with groups area available in the Project menu. The functions to manage groups are Group, Ungroup, Automatic Grouping, Ungroup All, Edit Group.

- “Group” creates a new group with all the currently selected items; - “Ungroup” breaks the selected groups; - “Add to Group” includes selected objects in the currently selected group; - “Automatic Grouping” is an option that automatically creates groups with items of a shape, i.e. rectangles, regular polygons, poly-lines, walls, etc.; - “Ungroup All” breaks all groups, including those not selected. - “Edit Group” opens a workspace where you can modify the selected group by editing, adding or removing members by using the normal drawing tools.

Edit a Group

Grouped objects can be edited all together like a single drawing object by stretching the handles of the bounding box of the group with the Arrow tool. A group can be moved, rotated, mirrored or scaled like any other object.

A group can be resized and moved with the Arrow tool. Properties applied to a group are applied to all the group members.

To select individual members of a group, hold down the command key and click the object. The object will be selected and be available for editing. This method is more suitable for quick editing operations.

You can also modify the members of a group through the Edit Group command as described above.