User Tools


10 Document and Present the Project

  • Text Blocks and Labels
  • Annotations and Tags
  • Dimensions
  • Detail Areas and Callouts
  • Layouts
  • Title Blocks
  • Viewports
  • Publish the Project

Text Blocks and Labels

This tool lets you insert multiline texts, and labels into your project. A text block has its own properties of font face, size, style, color, alignment and a background shape.

To set the properties of new texts, double-click the Text tool icon to open the Text Settings window or choose the menu item Edit ▸ Settings Window ▸ Text…

To change the properties of an existing text block, select the text object and double-click the Text tool icon or choose Edit ▸ Settings Window ▸ Text…

The Text Settings window provides easy access to all the graphic attributes of a text. If no text object is selected in the drawing, it shows the default values that are applied to all new objects; if one or more text objects are selected in the drawing, it shows the properties of the last text block in the selection.

In HighDesign Pro values and current graphic settings can be saved as styles.

While every other object is represented at the current scale, texts and labels are always at 1:1 real scale.

Text paragraphs can be styled both as a block, with one style for all the text, and as a styled text with multiple styles and colors. Rotated labels can only have one text style applied to all the elements.

Text Settings Window

- Font face, selectable from the list of font families installed in your system. You can also access the Font Panel to select a different typeface (only supported for the entire text object). Text size, in any supported measurement unit; open the pop-down menu to select a different unit. - Text style (bold, italic and underline) of the entire text; - Alignment (left, centered, right; top, middle, bottom), in both multiline texts and single line labels; - Character spacing and Line spacing controls; - Writing direction options for international characters and languages. - Border shapes: plain paragraph (no border), rectangle, diamond, hexagon, circle or oval; - Border Color. - Auto-fit options: fixed size, flexible height, fit-text. When flexible height is active, the height of the box adjusts to the number of lines of text.

NOTE To set the color of the entire text box, use the colors menu on the Properties Bar.

Text Box method

This is the method used to create text paragraphs with text styles. Click to set the base point, drag the pointer to set the width and height of the text field, exactly as drawing a rectangle, and insert the text in the input box; this box also supports the “Cut, Copy, Paste and Select All” commands.

When you define the text insertion box, the Text Styles bar opens allowing you to set the text styles within the paragraph.

This way you can have a text box with words of different font, size, color and style. It is also available a pop-up menu for the insertion of special characters. To confirm the text and end the insertion, click outside the text box field or push the OK button on the Text Style toolbar. Colors of the characters are displayed as defined by the parent block unless this is set to “none”. Setting a specific color for the selected characters overrides the block color.

To cancel the insertion, push the Esc key or the Cancel button the Text Style toolbar.

Rotated Label method

This method allows you to insert text labels and paragraphs with given angles. Differently from the Text Box method, texts created with this

method can have a single text style.

To create a rotated label, once the text is entered in the field, you can set the base angle by moving the pointer to rotate the label around the insertion point: click to end or set the given angle numerically. To create the label without setting the angle, push Command + Return.

To edit the content of a text object, activate the Text tool, select the object and click within the field: then modify the text; you can also edit the text by double-clicking the object with the Arrow tool.

To resize a text block, activate the Text tool, select the field and drag one of its angles. Text blocks only support resizing of width, not height, as the height of the object is calculated on its width and its contents and style properties.

Annotations and Tags (Tags Pro only)

Use this tool to add text notes with leader lines and arrowheads and tags. The text can be multiline and rotated, but only have one style of font, size and color. Leaders can be linear, circular, curved, or invisible. The construction process is similar for all types of leader: the first click defines the start arrow of the annotation and the second click sets the endpoint and the angle; the movement of the pointer and the next click define the landing. Enter the text in the input field.

HighDesign Standard/Pro: Annotations can be associative so that their position is determined by the parent element. Moving the parent element also moves the associated annotations.

When used on a project element, the annotation prompts basic information about that element. Supported object classes are hatches, symbols, walls, columns, doors and windows. For example, annotations added to symbols by default prompt a caption with the names of the symbol and the current view.

Tag is a method of Annotations (Pro). Tags are special annotations that automatically display selected information associated with certain classes of elements:

- Hatches - Symbols - Images - Architectural elements (Walls, Columns, Windows, Doors).

The Contents menu of the Settings window lists all the information that can be displayed in the tag label: select the options you wish to display.

The information can be computed or extracted from those added to the corresponding class of elements in the Object Info panel or in the Style/Type Settings window. Only the available information are displayed in the tag label.

Annotations and Tags Settings Window

- Text font, size and style - Horizontal alignment. Text notes are always aligned to the vertical middle. - Associative behavior (Standard/Pro). Switch on to associate the note to the clicked element. Allowed elements are closed shapes (rectangles, polygons, hatches, ovals) and design elements (walls, columns, doors, windows). Tags always have the associative behavior. - Contents pop up window (visible with Tags only). Through this window you can select the type of information displayed on the tag:

- Name - Size - Style tag - Instance tag - Description

- Leader style: none; lines; curve; arc. - Label rotation. - Frame Styles and size. The size of the frame can be calculated automatically based on the content of the text note, or set to fixed dimensions. When applied to architectural elements the frame style of Tags is automatic and varies with the class of the element. It can be changed afterwards through the Settings panel. - Frame padding defines the distance between the text and the frame. - Frame border color.

Dimensions

Use the Dimensions Tool to insert linear, multiple linear, radial, angular, ordinate and elevation dimensions. To set the dimension properties, either double-click the Dimensions tool in the Drawing Tools bar or choose Edit Settings Window Dimension to open the Dimension Settings dialog.

Dimensions Settings Window

This dialog is arranged in two panes: the Text and Graphics panes offer the fields, menus and options to setup the tool with the desired properties and configurations.

Text pane

- Preset menu PRO - Label font, size and style - Dimension units - Behavior: associative status - Label options: prefix; custom text to use in place of the measure; display units after the measure;. - Tolerances, upper and lower, and text size of tolerances, relative to the main label.

Graphics pane

- Arrowheads - open the pop-up to select shape and size of arrowheads; - Arrow size in the current units - Extension lines, long or short - Arrow gap, i.e. how much the extension line extends beyond the arrow, and extension gap, between the extension line and the source point. - Label options:

- position (middle, inside, outside, locked above and to the left of the witness line); - offset from the witness line;

- Label frame option; - Orientation of label, horizontal or aligned to the witness line; - Option to flip the text relative to the direction of the source points.

In HighDesign Pro values and current graphic settings of Text and Graphics pane can be saved as styles.

Methods:

Linear Dimensions

This method is used to insert linear dimensions between two points. The dimension line can have a generic angle or can be axis aligned and display the dx or dy distance with absolute values. To use this tool, click on the datum points and move the pointer to place the dimension line; if you move vertically or horizontally (following the guide lines that appear on screen) you create a vertical or horizontal dimension; otherwise, the dimension will be object- aligned.

Associative Linear Dimensions (not available in LT edition)

Linear dimensions can be independent or associative. Independent dimensions are defined by the source points as described above. Modifying the measured object does not affect the geometry and value of the dimension. Associative dimensions are linked to their source element and update their geometry and value automatically as the source object is moved or modified. Dimension and object can reside on different layers.

All the default properties and settings apply to associative dimensions in the same way as independent dimensions.

To Create an Associative Dimension:

1. Activate the Associative option, either in the Settings window or by clicking the Associative Dimensions button on the Properties toolbar, next to the Dimension methods. 2. Click the source object. Associative dimensions must be defined by clicking between two vertex points since they require only the definition of the source object. 3. Define the height of the witness line, i.e. its distance from the source object.

Associative dimensions are marked with squares on the source points. These squares are only visible on screen and are not printed nor exported.

Associate Dimensions

An independent dimension can be changed into an associative dimension, and vice-versa. To change the behavior of a dimension, select it and use the Behavior checkbox on the Dimension Settings.

When an independent becomes associative, it lacks the link to an actual source object. Also, deleting or otherwise removing the source object can cause the relative dimension to lose its link. When an associative dimension does not have its source object, or is not able to find it, the square marks are no longer visible and a yellow “caution” triangle appears near the mid point of the witness line. An unlinked dimension can be re-associated to its source object or a new element in two ways:

1. Using the command Tools Associate Dimensions/Annotations. Either select the dimension to link and begin the command, or begin the command and the click on the dimensions. With this method, it is possible to associate more dimensions in one run of the command. When you click on the dimension, a line is drawn from the mid point of the dimension to the cursor. Click on the new source object or element to link the dimension. 2. Using the caution triangle. Click the yellow triangle of an unlinked dimension to begin the Associate Dimension command. The procedure is then the same as above.

Multiple Linear Dimensions

This method allows you to insert horizontal or vertical aligned dimensions (dx or dy distances) of two or more progressive points. Once the first segment is defined, all following dimensions will respect the first alignment and height.

Radial Dimensions

With this method you can get radial dimensions of arcs and circles.

To create a radial dimension click on a circle / arc and move the pointer inside or outside the circle to place the dimension; click again to set the end point. A dialog will show you the available options of the information displayed in the label (radius, diameter, angle and length).

Angular Dimensions

This tool lets you dimension the angle between two lines: to dimension an angle, click on the first and on the second line; move the pointer to set the radius and the label position and click. If you click outside the datum lines the dimension will show the complementary angle.

Ordinate Dimensions

With this method you can calculate the perpendicular distance from an origin point. The origin is identified with the Absolute Origin of axes. Distances along the x- and y-axes to objects to measure are specified using extension lines, with the distances indicated numerically at their ends with text labels.

Set the Origin and click on the points to measure: move the pointer parallel to the X axis to get the Y distance and parallel to the Y to get the X distance. If you change the origin, Ordinate dimensions will be updated automatically.

Elevation Dimensions

This method can be used to add elevation dimensions to your project.

To create elevation dimensions, set the “zero” datum, that is the Absolute Origin, and click on the points you need to measure. All dimensions will display values relative to the origin; if you move the origin, all other dimensions will change their values accordingly.

Edit Dimensions

Dimensions can be edited to change their position, distance from the measured object and placement of the label. With the Dimension Tool active, click one of the extension points and move the pointer to modify the dimension; if the witness line is horizontal or vertical, the movement will be direction-constrained.

Click on of the endpoints of the witness line and move the pointer to change its distance from the extension points.

Click on the control point of the label to edit its placement along the witness line; you can also place the label outside the dimension: in this case a line will extend from the witness line to the label.

Radial dimensions are always associative: edit the measured object to change its position and values; click one of the vertices of the extension line to change its position and place the label inside or outside the circle.

Angular dimensions can be edited to modify the radius and the width of the arc and the label position: click on the arc and move the pointer to edit the radius.

Ordinate dimensions, that are linked with the origin, can be edited by moving the control points with both the Arrow tool and the Dimensions tool.

Elevation dimensions can be moved with the Move tool: the measure will be automatically updated with the new position.

Detail Areas and Callouts (Pro)

HighDesign Standard and Pro provide the Detail Area tool, a special tool designed to define rectangular areas of the current drafting sheet to be printed or to generate details of a larger project (Pro).

These regions of the drawing can be printed alone, like portions of a larger project. Detail areas can have a name, a color and a layer, and they are saved within the project like any other object.

If a Detail Area is linked to a detail of the project it is called Callout (Pro).

Detail Area and Callout Settings Window

When the Detail Area is linked to a detail sheet, the Callout options of the Settings window are enabled allowing you to specify the Head’s shape of the Callout (Round, Hexagonal, Oval, Rectangular) and to customize the Text:

- Font menu; - Button to open the Fonts panel of the System; - Button to select and load existing Text Styles; - Text size menu; - Text Default Styles (Bold, Italic, Underline).

Create and Edit Detail Areas and Callouts

To create a detail area, click and move the pointer to draw a rectangle; click to set the area and insert a name in the input dialog. The detail area is displayed with a dashed and dotted border as a default: the name of the detail area is displayed as a label in the top left corner of the area.

If the area is selected, a triangular button close to the label of the area shows up: click on it to open the menu with the options to rename the area or create a new detail from the area.

When a new detail is created and linked to the area, we have a Callout. A Callout is displayed as a detail area with a head, a marker showing the Detail ID on the top side and the number of the Layout on the bottom if that detail is displayed as a viewport on a layout.

You can decide to hide detail areas during a normal design session by choosing the menu item View Detail Areas. The same command can also be used to show hidden detail areas.

To edit an area, select it and, with the Detail Area tool active, click one of its vertices and move the pointer. To change the name of an area, select it and click on its name label; then insert the new name in the input dialog.

To change the position of a Callout head, select it and move the marker along the border of the area by the definition point of its leader.

Once you have created a detail area, you can open the Print window and select it from the Print Area pop-up menu as a printable portion of the project.

Present the Project

Layouts (Pro)

Layout Sheets are used to arrange the Views of the project and the Title Blocks on pages of specific paper sizes corresponding to the drawing standards.

These named pages are intended for publishing and output purposes, therefore layouts have some characteristics that are unique and specific to this environment:

- Layouts are opaque sheets; - The scale of the layout is always 1:1 real scale; - Layouts have a paper size, defined as default by the Paper Format settings of the project; - You can choose to show the current print margins;Layouts always have a sheet ID; - You can add a Title Block by choosing from the existing ones or you can create a new one; - There are the options to show the frame border and the centering marks; - You can set the nominal scale of the views; - You can enter text information to the current layout to be shown on the title block; - You can create one or more viewports to show and arrange selected views of the project at the desired scale; - The available set of drawing tools is limited to sketching and documentation tools.

Manage Layouts

As for the other sheets of the project, use the Project Browser panel to create and access the Layouts. The Object Info panel shows all the options, settings and information of the current layout and is divided into four sections:

- Sheet, which displays name and generic sheet information like scale and units; - Paper Size, to change the size of the current Layout only; - Layout Settings, to set sheet ID, title block and nominal View Scale; - Layout Info, to set the issue date and enter text information.

Title Blocks (Pro)

A Title Block is a descriptive preset format for a layout and includes information about the author or design firm, about the project, client and site location; The title block can also show information about the specific sheet like sheet number or issue date.

Create a new Title Block

You can create a new Title Block through the Title Block menu on the Object Info panel of the current Layout or through the Project menu. A specific workspace shows up with the graphic tools required to draw the title block and the panel to set the title block name and manage the text attributes to enter.

Title Block Attributes

Attributes are text values with dynamic content. The pre-defined attributes can be selected through the menu on the Title Block panel. These attributes are separate as:

- Layout attributes which correspond to the information entered in the Layout Settings and Info sections of the Object Info panel of the current Layout; - Project attributes corresponding to the information entered in the Project Information panel of the Project Settings window.

Attributes of the title block can also be custom attributes and once you click the Add button, the Define Attribute window opens displaying the options and input fields.

Insert a Title Block Attribute

To insert an attribute on the title block, click on the desired location. Attributes can be moved or aligned as graphic objects and edited through the Edit Attribute button of the Title Block panel.

The Save button creates a new Title Block on the User Library which is immediately available for use in the current layout and in new projects.

A Title Block can be inserted even in a layout of different size from the one it was created for, depending on its bounds. When you select a title block it is automatically inserted at its default position on the layout as a preset: anyway, you can move it to any other position as a drawing object.

Viewports (Pro)

Viewports are scaled representations of the project, acting as windows showing views of selected sheets or specific areas of sheets, and providing basic information about the views. Viewports exist within Layouts only. To create a new Viewport use the button on the lower right corner of the Layout canvas or select the “Create Viewport” command on the Project menu.

Set up the Viewport

The Viewport dialog shows two panes with the Drawing and Title Mark options. The Drawing pane provides the options of viewport window and selected view:

- Source drawing (drafting sheets or details of the project); - Scale of the view, which can be different from the original scale of the selected sheet; - Angle of the view, by moving the angular slider or by entering the value in the field; - Size of the Viewport - automatic, by the extents of the source drawing, or custom, by drawing the rectangle of the viewport; - Filter applied to the view (by project, by layer, black and white, grayscale, etc.).

On the Title Mark pane you can set the position of the title mark within the viewport, the name of the view, the option to show scale and other graphic options.

The available options are:

- Show/Hide Title Mark; - Position of Title Mark within the viewport on the upper or bottom edge; - Title of the Viewport; - Font options - font menu, button to open the Fonts window, button to select existing styles, font size and units menu, default text styles; - Show/Hide Scale of the view; - Show/Hide Extension Lines of the Title Mark; - Extension Line options.

Insert and Manage Viewports

You can insert the viewport on the layout as an object of predefined size or you can draw the viewport as a rectangle by its diagonal, depending on the selected size option. The center of a new viewport corresponds to the center of the selected source drawing: if you wish to display a specific area of the drawing, select the viewport, click inside and move the source drawing within the viewport till the desired area matches the center of the rectangle. When the “Snap Inside” option is selected you can move the source drawing within the viewport by any point with snap precision.

A viewport can be moved within the layout as a drawing object with its properties: frame and background can have their color and line style.

Viewports created as rectangles can be resized by their selection handles, either vertices or midpoints, or through the Object Info fields of Viewport Geometry. Viewports created by the extents of the source drawing cannot be resized.

The information displayed in the title mark of the viewport can be quickly set and edited through the ID section of the Object Info panel which provides the Id and Name fields and the button to open the Viewport settings dialog.

For a quick access to the source sheet of the selected viewport, click the link icon on the upper left corner of the viewport.

Publish the Project

Export to PDF (Pro)

With this function available on the File menu it is possible to create single page or multiple pages vector PDF documents which can be edited with other applications and printed with large format printers and plotters.

The options available in the Publish to PDF window are:

- Document pages: “Single Page” creates a one-page PDF document; “Multiple Pages” creates as many pages as the visible sheets. - Include copyright info: this option adds information about the project from the Info pane of the Project Settings window. - Publish menu brings the following options:

- Current View to export the project as it is currently visible on screen; - Custom to select the desired sheets to export; - All Layouts to create a multiple page PDF document with all the layouts of the project; - List of the available Project Views to export the selected one.

- List of all Sheets, Details and Layouts of the current project: select the sheets to include in the PDF document for custom publishing. - Page Size menu. Available options are:

- Fit Drawing Extents: page sizes are calculated on the extents of the drawings. - Available Sheet Size: this sub-menu lists the sheet sizes of project if already set; all sheets get the size from the selected one. - ISO, ANSI, US ARCH standard sizes sub-menu.

- Orientation of the selected page. - Option to scale the drawing to fit the selected page. - Option to apply the graphics filters to the PDF. On macOS, the filters include Quartz filters.